summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-08 22:54:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-08 22:57:11 +0200
commit3779e10b09f50a3976c4346d3a46ae84521705f8 (patch)
tree37672927d0fa6409f4088ff3a8ad19e51b65a68f /dev-python
parentprofiles/base/use.mask: remove consolekit use flag (diff)
downloadgentoo-3779e10b09f50a3976c4346d3a46ae84521705f8.tar.gz
gentoo-3779e10b09f50a3976c4346d3a46ae84521705f8.tar.bz2
gentoo-3779e10b09f50a3976c4346d3a46ae84521705f8.zip
dev-python/passlib: Bump to 1.7.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/passlib/Manifest1
-rw-r--r--dev-python/passlib/passlib-1.7.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/passlib/Manifest b/dev-python/passlib/Manifest
index 2da76b89308b..dd4d6da38fe6 100644
--- a/dev-python/passlib/Manifest
+++ b/dev-python/passlib/Manifest
@@ -1 +1,2 @@
DIST passlib-1.7.2.tar.gz 649654 BLAKE2B 40279113d9ff633cea47222f2d72af0abee78dc52a9b46adf66aaae213594eaae7f245cc80004f85b5055b882741b4bedfd81ee39132db23760d37a34e87ac6a SHA512 1ea0654b177b5ab2e1a7e5c3949642c34805ace6e4e4a0f82fafdb3f374edd99c667906ce598c335b668da049860648d5cbebb3e62d775898d5b0cb8cfc7bf53
+DIST passlib-1.7.4.tar.gz 689844 BLAKE2B 38f616105ba70cf93cf36383c73f2a4da7bf66ced2844effffe74d9f7c29ee0aece5652974dd1414f16e32fbe6957e2e921cf01bc59daa70195a6d50a4a3bf2f SHA512 350bd6da5ac57e6c266ffe8bf9684c8c2cce3fc6b513eb6c7bc1b302d2d8a1b701e9c01c953782520a2ac37b7ec1f6d7bd5855f99f6ee0e2dbbf33f2d49a9530
diff --git a/dev-python/passlib/passlib-1.7.4.ebuild b/dev-python/passlib/passlib-1.7.4.ebuild
new file mode 100644
index 000000000000..d1db1aa27998
--- /dev/null
+++ b/dev-python/passlib/passlib-1.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Password hashing framework supporting over 20 schemes"
+HOMEPAGE="https://foss.heptapod.net/python-libs/passlib/wikis/home"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="+bcrypt doc +scrypt +totp"
+
+RDEPEND="bcrypt? ( dev-python/bcrypt[${PYTHON_USEDEP}] )
+ totp? ( dev-python/cryptography[${PYTHON_USEDEP}] )
+ scrypt? ( dev-python/scrypt[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/scrypt[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
+}