summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-24 14:08:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-24 16:31:26 +0200
commit3817385e90801f2d5dbbdc6e17a4616a6691f93e (patch)
treec2f2c4b09dae708df8c13d291caff6dfb2c7c428 /dev-python
parentdev-python/boto3: Bump to 1.14.27 (diff)
downloadgentoo-3817385e90801f2d5dbbdc6e17a4616a6691f93e.tar.gz
gentoo-3817385e90801f2d5dbbdc6e17a4616a6691f93e.tar.bz2
gentoo-3817385e90801f2d5dbbdc6e17a4616a6691f93e.zip
dev-python/hypothesis: Bump to 5.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.21.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index ceb273629108..7d156f89ebf5 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -7,3 +7,4 @@ DIST hypothesis-python-5.19.1.tar.gz 9023768 BLAKE2B d1aa7c7a537e9f4ac0f33c12fa0
DIST hypothesis-python-5.19.2.tar.gz 9023874 BLAKE2B e4c713a574547eccfd9d9fc36c2ef192795922c7fc97eb8a59a61506d2d89101a02e0f81fda3d703aac03ed4dc902f47f07ea50375efbc5b1ae7c24f7ea3f058 SHA512 f0a55e8039666dc664760483e6a6cae3371b627912f89215c76430d71bfc80426beef3001dd7415686d75387ceb1a0810068fded11ec728d20f81936bd0b9717
DIST hypothesis-python-5.20.2.tar.gz 9024252 BLAKE2B 91fc3c24e00301c2df16ca408f1efce512753bd8ea37ae912d4a10be455b42b830a72659394a88749d261cda08f5519c2cc455339094c025d5cb9e9ffede654e SHA512 8819cf3cce70a16d5e551d38ac54cd27a9649a775416d01452694a86dc40c840ace5d8edda6aed5680a98908e6266fbe6dcc4e6d6d9d3bceb8417d341e3e7a07
DIST hypothesis-python-5.20.3.tar.gz 9024258 BLAKE2B 75bc1e868061be9c8d0377143f5f45221e182eef54c93aa0445dac1b087c35472af6a32d7b6ee8d69bfb9ed16a14927e8572f98b7b3d02fbd880d979b54b862b SHA512 2b8819c425f607e300ad569115cc72b3ab45026a4d82b7f52a66fc60fe92d392a4ca0dac3260969409006958a81e69fbaac1b4612bfa6236e27f4d8f996acb89
+DIST hypothesis-python-5.21.0.tar.gz 9025422 BLAKE2B acd6f3b0f945ae65656af2a718add06fe440e221fda7793e3557ab194ccee4c6327e7946a58ce51e9efe3c08274888a648d9021c49fdcf663a04c28b99a0f636 SHA512 1921e5ea8d0f2a6e55d80611004d35671f7a7a02cb8a8f101b45e64e4ef23f9c2c8a9c467fb6c9f33ae440622020e1ad504f51a7d725a6449ca715ad1f373e40
diff --git a/dev-python/hypothesis/hypothesis-5.21.0.ebuild b/dev-python/hypothesis/hypothesis-5.21.0.ebuild
new file mode 100644
index 000000000000..54efc2972e96
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.21.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}