summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-15 23:34:41 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-15 23:34:41 +0300
commit38937972dd8ccf257a9cb9e426e17a5c0090b7be (patch)
tree2036b2b92bff5910a2bfe25baa8182dd1ebe03f4 /dev-python
parentdev-python/pyotp: add 2.7.0 (diff)
downloadgentoo-38937972dd8ccf257a9cb9e426e17a5c0090b7be.tar.gz
gentoo-38937972dd8ccf257a9cb9e426e17a5c0090b7be.tar.bz2
gentoo-38937972dd8ccf257a9cb9e426e17a5c0090b7be.zip
dev-python/indexed_gzip: add 1.7.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild
new file mode 100644
index 000000000000..11a55ef5459b
--- /dev/null
+++ b/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="
+ https://pypi.org/project/indexed-gzip/
+ https://github.com/pauldmccarthy/indexed_gzip/
+"
+SRC_URI="
+ https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # strip custom "clean" command that doesn't support "-a"
+ # https://bugs.gentoo.org/838955
+ # TODO: this can be removed once distutils-r1 stops using clean
+ sed -e '/cmdclass/d' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
+ epytest
+}