summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-06 17:18:11 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-06 17:20:47 -0800
commit39527f242f5108daceb5941302a872714a502836 (patch)
treee95311de1e8401c97a751e26a70afe38cdab73bb /dev-python
parentdev-python/colorclass-2.2.0-r1: Revbump, fix tests, add py38 and pypy{,3} (diff)
downloadgentoo-39527f242f5108daceb5941302a872714a502836.tar.gz
gentoo-39527f242f5108daceb5941302a872714a502836.tar.bz2
gentoo-39527f242f5108daceb5941302a872714a502836.zip
dev-python/tabulate-0.8.6: bump, add py38 and pypy{,3}, remove pandas dep
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tabulate/Manifest1
-rw-r--r--dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch80
-rw-r--r--dev-python/tabulate/tabulate-0.8.6.ebuild37
3 files changed, 118 insertions, 0 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index c3b9407e80e2..f7f0bd116c8d 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1,2 +1,3 @@
DIST tabulate-0.8.1.tar.gz 45666 BLAKE2B f46a0c8bed50e37a2d536d28fe822fb92fbc124c7ac4c29260b6a7ab9828588f49b7e94ec8925505ef9724b1fb4647e5e9207d29b2f3a2f526641ac7ac229ce0 SHA512 f724fbabee53c738c846a5cf645470f5f97074e2b33eb030b4859478931661dac53e5446d77a656553e2dec323230bb116d350997e1407d794382f537e6dfdf5
DIST tabulate-0.8.3.tar.gz 46234 BLAKE2B 1310de381265bf150cdef72b653175b1ab95a8339bf1934cece830ce9e644ed9d3d441eb3c3721509368334d11160054aa4d75a17751e493c47dbeee22c466e2 SHA512 7f0205a4d80ed0b426a45622a3b8ec0a9b77cf6d67c1207db7fbc20a12e83a15748e63d5f8e5e65fa348b6265fd0cac93be4d04f9c1c182476b93507e1131cbf
+DIST tabulate-0.8.6.tar.gz 39420 BLAKE2B 28cd8c175b258b56a406a78d7891919a49c867d848843365605ccdcb8ba0b307f1448967a124d57b0f6264169104c9cccc84982fea666a035a265a3c9f10cc43 SHA512 ec4d7a7f20db306be1a460276e0b1b1e63fd1ca14b208a45a297508bddbc07b034e03fcb5ff67fe5e2b9419f308900675994a6dccef755c975ad0b1e9124072f
diff --git a/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch b/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch
new file mode 100644
index 000000000000..b75df197f80e
--- /dev/null
+++ b/dev-python/tabulate/files/tabulate-0.8.6-avoid-pandas-dep.patch
@@ -0,0 +1,80 @@
+diff --git a/test/test_input.py b/test/test_input.py
+index 5443ab9..8a1d2e5 100644
+--- a/test/test_input.py
++++ b/test/test_input.py
+@@ -4,6 +4,7 @@
+
+ from __future__ import print_function
+ from __future__ import unicode_literals
++import unittest
+ from tabulate import tabulate
+ from common import assert_equal, assert_in, assert_raises, SkipTest
+
+@@ -246,6 +247,7 @@ def test_numpy_record_array_headers():
+ raise SkipTest() # this test is optional
+
+
++@unittest.skip("avoid extra unnecessary deps")
+ def test_pandas():
+ "Input: a Pandas DataFrame."
+ try:
+@@ -267,6 +269,7 @@ def test_pandas():
+ raise SkipTest() # this test is optional
+
+
++@unittest.skip("avoid extra unnecessary deps")
+ def test_pandas_firstrow():
+ "Input: a Pandas DataFrame with the first row as headers."
+ try:
+@@ -285,6 +288,7 @@ def test_pandas_firstrow():
+ raise SkipTest() # this test is optional
+
+
++@unittest.skip("avoid extra unnecessary deps")
+ def test_pandas_keys():
+ "Input: a Pandas DataFrame with keys as headers."
+ try:
+diff --git a/test/test_output.py b/test/test_output.py
+index 1eb67c1..2106c88 100644
+--- a/test/test_output.py
++++ b/test/test_output.py
+@@ -4,6 +4,7 @@
+
+ from __future__ import print_function
+ from __future__ import unicode_literals
++import unittest
+ import tabulate as tabulate_module
+ from tabulate import tabulate, simple_separated_format
+ from common import assert_equal, assert_raises, SkipTest
+@@ -1176,6 +1177,7 @@ def test_unaligned_separated():
+ assert_equal(expected, result)
+
+
++@unittest.skip("avoid extra unnecessary deps")
+ def test_pandas_with_index():
+ "Output: a pandas Dataframe with an index"
+ try:
+@@ -1199,6 +1201,7 @@ def test_pandas_with_index():
+ raise SkipTest() # this test is optional
+
+
++@unittest.skip("avoid extra unnecessary deps")
+ def test_pandas_without_index():
+ "Output: a pandas Dataframe without an index"
+ try:
+@@ -1222,6 +1225,7 @@ def test_pandas_without_index():
+ raise SkipTest() # this test is optional
+
+
++@unittest.skip("avoid extra unnecessary deps")
+ def test_pandas_rst_with_index():
+ "Output: a pandas Dataframe with an index in ReStructuredText format"
+ try:
+@@ -1247,6 +1251,7 @@ def test_pandas_rst_with_index():
+ raise SkipTest() # this test is optional
+
+
++@unittest.skip("avoid extra unnecessary deps")
+ def test_pandas_rst_with_named_index():
+ "Output: a pandas Dataframe with a named index in ReStructuredText format"
+ try:
diff --git a/dev-python/tabulate/tabulate-0.8.6.ebuild b/dev-python/tabulate/tabulate-0.8.6.ebuild
new file mode 100644
index 000000000000..a62b688f38ed
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.org/project/tabulate/ https://github.com/astanin/python-tabulate"
+SRC_URI="https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-${P}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*')
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tabulate-0.8.6-avoid-pandas-dep.patch"
+)
+
+distutils_enable_tests nose