summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-13 00:17:58 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-13 00:17:58 +0200
commit39a916f3bd554d5827e7c2fedac25b72d0941d91 (patch)
tree80fbca2cb05f86a2ac7527c9c3aa9585b941d1d1 /dev-python
parentmedia-video/gaupol: remove old (diff)
downloadgentoo-39a916f3bd554d5827e7c2fedac25b72d0941d91.tar.gz
gentoo-39a916f3bd554d5827e7c2fedac25b72d0941d91.tar.bz2
gentoo-39a916f3bd554d5827e7c2fedac25b72d0941d91.zip
dev-python/denonavr: bump to 0.7.4
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-0.7.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index af72c42e2da1..bc11722e0bc7 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1,2 +1,3 @@
DIST denonavr-0.7.2.tar.gz 61673 BLAKE2B 98de89e385f51d6a13e1b365074a8bed7303fb4e666c608f547f9f515924539d6f54349483f4a78ed8968295cb1c3196e8713c05f1e10aca7ad290f6114bb29c SHA512 941f8133e19c41df9525f4a9c705ce4dc7a35eef493fa465df52a50fb752f6d23818c7046b7e8281af58b285f65b983bead1c77f49c61fd47743984a4a3f6a4a
DIST denonavr-0.7.3.tar.gz 61735 BLAKE2B 5a6a8fab2f416cb34ac3078cc65fa92342de81a21f1710f6460fb00c1d255d7a5e208d3d9f9904c063004456e6e3447a08c677b95fc216bab1153060bafa8dd2 SHA512 51d559bf0db1ca9fcd6239046d2c2a149ac22e99aec331f10c7c6d59b2c9290aa66477093f4e707caf24f9ff78572659c3ffe2c9d508a28b344a1838e8cdee5d
+DIST denonavr-0.7.4.tar.gz 61901 BLAKE2B 70e4ba2b261d2007f80e52c43bf3fca4b41d2e53067e82aa46010334450b2a81723045f377956340d7b7d4388e829b8648a267a89c7ba69fd1ce28ca1f42ca10 SHA512 7ac9a25ecb46f0556acf48c1427154d3282a59185640aa85f2ae5d638d4b7fffea5b53a1964c621751e42d1d45fd6a6d5c273e1c850e2e473159bd099394e24e
diff --git a/dev-python/denonavr/denonavr-0.7.4.ebuild b/dev-python/denonavr/denonavr-0.7.4.ebuild
new file mode 100644
index 000000000000..4a3aab119639
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="https://github.com/scarface-4711/denonavr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}