summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-08-06 01:19:25 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-07 22:43:32 +0200
commit39d9fe33a1b87bb6f2dbd63a9e76579fd8142bd4 (patch)
treeadd8e338f8ddd19ef37a0cef7de341dbe8216263 /dev-python
parentgnome-extra/chrome-gnome-shell: version bump, remove old (diff)
downloadgentoo-39d9fe33a1b87bb6f2dbd63a9e76579fd8142bd4.tar.gz
gentoo-39d9fe33a1b87bb6f2dbd63a9e76579fd8142bd4.tar.bz2
gentoo-39d9fe33a1b87bb6f2dbd63a9e76579fd8142bd4.zip
dev-python/jaraco-collections: version bump to 1.4.1.
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2028 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.4.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 4fa150b439dc..b3000a4d3740 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.collections-1.3.2.tar.gz 8965 SHA256 8587fcfa89d81d639687184502cddb4868e3dc5b9a73827ee2bfe8455ab27e57 SHA512 2369e9194fba5b25294ff5977def201b14d1ae72ddce08b5163995fcb530e55046f24354a0144f9272e822c38b468f493f262d56d2d0f6edab315be90f5fca70 WHIRLPOOL adb24717b71bce2f4d4ccae216eb9fd638bd8457a6c465c73fff32e045900ca08e8cc3a2bd49e9f55f6d7897caaae2894a74c10eac343c40498e7ab2a18c712a
+DIST jaraco.collections-1.4.1.tar.gz 10456 SHA256 43d0221be38fa0d8da339a149829800c8c3f843f379c09f3f8f1d99125110936 SHA512 1f9eca787efb427a73b5f03e144a2a95e5740580e21e9857a376d76dd35f39066c3a06056eaf78f72de2f97e4fc70805467fcc516f989ba4785e3f3d9354a538 WHIRLPOOL c37a851f1ab041554c1d9a54565e5671350bc750d31d1569a4415c5c215557739145b3a4992546d715a013695ef86cb788c47b4eb72940a29fdc17a9300399bb
DIST jaraco.collections-1.4.tar.gz 9615 SHA256 82af38e4f8ef59ef5b44738561dd766f944e145a7ce39751744783f70f779ccb SHA512 dbb7c07bd6a7b4ef41aad1fef55b760447c94aea7036b56ed6fc02deba0720c2cb644fa47598f3997a307343dd1672d4afdd745fad3e02e37257ea714c02634a WHIRLPOOL 05c22e5b1c0d3725c4f0f486ff628991103643264c0e3338172d585be155eb2ba509182b652ed5484cd07cad13b0486829df2e8e9abd5450d7417ffb19d491f4
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.4.1.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.4.1.ebuild
new file mode 100644
index 000000000000..357e4967dc31
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.4.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && ! has_version "dev-python/jaraco-text"; then
+ die "Ensure dev-python/jaraco-text is installed or the" \
+ "test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}