summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-24 19:49:37 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-24 19:49:37 +0200
commit3a5c356b8bd6c732aeeb8c85ac59a433ad63da06 (patch)
treeb404c93af9aa1d9c99e7b6c7ced6774e0eaaba19 /dev-python
parentdev-python/typed-ast: add 1.5.2 (diff)
downloadgentoo-3a5c356b8bd6c732aeeb8c85ac59a433ad63da06.tar.gz
gentoo-3a5c356b8bd6c732aeeb8c85ac59a433ad63da06.tar.bz2
gentoo-3a5c356b8bd6c732aeeb8c85ac59a433ad63da06.zip
dev-python/pooch: add 1.6.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pooch/Manifest1
-rw-r--r--dev-python/pooch/pooch-1.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index e38f430514df..08ddb6d445b6 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1 +1,2 @@
DIST pooch-1.5.2.tar.gz 61167 BLAKE2B 36c3ac00ae1d05b688fabc31ae9eb88536d717a3dd179a02bf76f9c8066520bc165af0a71d5cd514e7c9f2422c4a3ee189cf93215bc9a9189bf9f20a77f95e61 SHA512 acb1a48e94a97f79503125f0cf1312d715719ec32817771d2e19d2bd89b2cfd34b50221d67d1854cd93818140d8536f6f5b3db1ae0bbb185fffa2cf9886f98da
+DIST pooch-1.6.0.tar.gz 52318 BLAKE2B c5cdf04a27a5754accee5a4522d5e6a51c4e71b7034cd570c6a2f30bc580ba9c15e0717be792e7cdd020ca745e6813a63681ce966ad61c0ed4aaa8b84829b920 SHA512 e1b6253b8879ef172bd6370139a7807355c7e1c03a1626ac46cb083b1f7d8beb5a8adb08c0828eb34e96a7164211d2dc7da214fd0176eb0606fe4ff47911257c
diff --git a/dev-python/pooch/pooch-1.6.0.ebuild b/dev-python/pooch/pooch-1.6.0.ebuild
new file mode 100644
index 000000000000..8e922a76d068
--- /dev/null
+++ b/dev-python/pooch/pooch-1.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Manage your Python library's sample data files"
+HOMEPAGE="https://github.com/fatiando/pooch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-localftpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}