summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-06-25 21:45:37 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-06-25 21:45:37 -0400
commit3bd4fddb2536dfd653f33e438925108090408e7b (patch)
treed54cfced62827ce8f3c68b19e321257e446ac50b /dev-python
parentdev-python/rpyc: amd64 stable (diff)
downloadgentoo-3bd4fddb2536dfd653f33e438925108090408e7b.tar.gz
gentoo-3bd4fddb2536dfd653f33e438925108090408e7b.tar.bz2
gentoo-3bd4fddb2536dfd653f33e438925108090408e7b.zip
dev-python/python3-lxc: new package
This used to be bundled directly in LXC's package which is why I keyword it with the same arches as app-emulation/lxc. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python3-lxc/Manifest1
-rw-r--r--dev-python/python3-lxc/metadata.xml15
-rw-r--r--dev-python/python3-lxc/python3-lxc-3.0.1.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python3-lxc/Manifest b/dev-python/python3-lxc/Manifest
new file mode 100644
index 000000000000..b6e6418b6d81
--- /dev/null
+++ b/dev-python/python3-lxc/Manifest
@@ -0,0 +1 @@
+DIST python3-lxc-3.0.1.tar.gz 27424 BLAKE2B ffdf128e06d7b256652588af7c464045479ce907d2119dfe9780737c7bd5f3008c01d834a79f63932bfa51e3094a9d40af46c4cb6c3be72108205d65a8ee3d11 SHA512 7e6b6cb9a02e5af8b3fc8aeefff2954c68d2d1154751fa97a70bce86131021571e15db86bb0d6900a93dda78247e37b75cdfe250bf4d1b7548dc8383ed3d45f6
diff --git a/dev-python/python3-lxc/metadata.xml b/dev-python/python3-lxc/metadata.xml
new file mode 100644
index 000000000000..168b59d5f4a5
--- /dev/null
+++ b/dev-python/python3-lxc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vdupras@gentoo.org</email>
+ <name>Virgil Dupras</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>virtualization@gentoo.org</email>
+ <name>Gentoo Virtualization Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxc/python3-lxc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python3-lxc/python3-lxc-3.0.1.ebuild b/dev-python/python3-lxc/python3-lxc-3.0.1.ebuild
new file mode 100644
index 000000000000..d448c380fbc9
--- /dev/null
+++ b/dev-python/python3-lxc/python3-lxc-3.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxc/"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-emulation/lxc-3.0"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"