summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-07-11 17:18:36 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-07-11 17:19:27 -0500
commit3bf1a1743b3910e3e055d54aa78564e5263488e7 (patch)
tree62e0b4595e1d4290d79a12be9937c5f177666754 /dev-python
parentdev-python/django-cors-headers: 3.0.2 bump (diff)
downloadgentoo-3bf1a1743b3910e3e055d54aa78564e5263488e7.tar.gz
gentoo-3bf1a1743b3910e3e055d54aa78564e5263488e7.tar.bz2
gentoo-3bf1a1743b3910e3e055d54aa78564e5263488e7.zip
dev-python/django-debug-toolbar: 2.0 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 8533b8502424..d14cb7886d6d 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,2 +1,3 @@
DIST django-debug-toolbar-1.11.tar.gz 321727 BLAKE2B 89eab65bc0306da9fd81affbffc312eb99d04f19c66d9e5c6016df323a987e1b3fe1d177d409d68548aede869ed6d3e71adb5f4f4e5cb85a9ab431eca5664033 SHA512 8085b02fc25571e7b3bff02ff2bda8bec81a6000c6ed9e2aea10ec45eb1a3e5adf2ee95fcfbb0a11660fd716ebf2e35a9bdefbaf767b4afc732368a197857e62
DIST django-debug-toolbar-1.5.tar.gz 315928 BLAKE2B 8dde3c655baa6bd5f3b5d3ae0ba57b8c5746fc41bcfae9f506ad5c49ff64cdb51f0b9d67ee42695f884493cf21bd76fdcf943d88d97641b5d804d54c59163562 SHA512 9a421b80016bdaee8dd3ba2a9b7c3b788b54a4f464cdd5697e36536268e4d3d926bf77088a715e87f192dc8a20a100d8adac68c9c26a1191a5343e377240bf64
+DIST django-debug-toolbar-2.0.tar.gz 321249 BLAKE2B cd4f9e7d55deaf404369ba89eaffe0c730a058450c8368e39bfe3f5562019f5978ff33b93dc0463dc0fa6e6ba1047335d45997929dc3d2b576a78ff7cd5f75f0 SHA512 8440705a2e38f2c035a1dde4eb14ec829ead502cbbebcae46889e26877c0843389107bf14249afe9742638c4880b362fd699aed935e271bc1ade8f0a54bfea46
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild
new file mode 100644
index 000000000000..fe591fca5ade
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.org/project/django-debug-toolbar/
+ https://github.com/django-debug-toolbar/django-debug-toolbar/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.0[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # Prevent non essential d'loading by intersphinx
+ sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+
+ # This prevents distutils from installing 'tests' package, rm magic no more needed
+ sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}