summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-24 22:41:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-24 23:52:37 +0100
commit3c016b2508832127605bb3cdf8b3ed76869daea4 (patch)
tree4bfdec65e0edc35393aa03620e700249f23ae4cc /dev-python
parentgames-strategy/war1gus: Bump to 3.2.0 (diff)
downloadgentoo-3c016b2508832127605bb3cdf8b3ed76869daea4.tar.gz
gentoo-3c016b2508832127605bb3cdf8b3ed76869daea4.tar.bz2
gentoo-3c016b2508832127605bb3cdf8b3ed76869daea4.zip
dev-python/moto: Bump to 2.2.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-2.2.20.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index e2fa903e6118..f456852a14dd 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -6,3 +6,4 @@ DIST moto-2.2.16.tar.gz 1982590 BLAKE2B 016760c1eebd418ddb281f9cf438d9e13c868409
DIST moto-2.2.17.tar.gz 2013217 BLAKE2B 6fe6dd23e96fe8ba210fc9bbb400ced7c27aa6626097c523579482d58709fbf2d22e217bdab604017ee17c45b4093c8106e15e5894484face28c07bba85d42ea SHA512 73dfa0f15afd299e2c5b4c7833a73b1a7537248b8b332258868bac01890c1861e9a62b6fb634d795d4e37e5505cc51008f1048154044a8238049de5b21f31251
DIST moto-2.2.18.tar.gz 2077837 BLAKE2B acb4c428e6cc00711e186a209d61e00366954dabf9ad750f7d639d822daaf7e35399ab8a317fa32756113d41bff27d236be79b7c99b4f2ddbd8fb415144cd985 SHA512 5d416b59b9a3bd97b98ea5196bcfc25accb2bed83e9782cda48acf8ec52a9e304e9fe5edfdd5dda60376df06b7a9c0709acec08d058a99127cc34ef2905ba5b3
DIST moto-2.2.19.tar.gz 2083677 BLAKE2B e8471c4acccd213a80b4636a1da2a404f1ea2c10750a80059999212f8ab721ab900c08e29ebb069c271063bf2b67dd837fd311ff25f304956a8551bbc7eb936e SHA512 cd549fad44820900efc28e8d6834c588dac57c44a09214f6f5e51894207e9b1f88300975d60390c14252be29d66696dbe13d484ede87c23c6d16f4c39ba7f2a2
+DIST moto-2.2.20.tar.gz 2077649 BLAKE2B 595d9536b21ba442fcf0b9b40e61cc9d3105e220661f67d842cd5e9660ed4ff561e0ea742083e167ef11312b762b204e82381550845a06d6b5a694793adc0c67 SHA512 ac853989ec4822a72139ed62f7bc8b01a91ef2a424b4e622fd0cc6828b3dd21d3a433ba8d50cda5e5b4c03859653d71f9431b7ce2416255be3cf129b1a02e200
diff --git a/dev-python/moto/moto-2.2.20.ebuild b/dev-python/moto/moto-2.2.20.ebuild
new file mode 100644
index 000000000000..b0d11c5e4c29
--- /dev/null
+++ b/dev-python/moto/moto-2.2.20.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-tempfile[${PYTHON_USEDEP}]' python3_{6,7})
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unpin indirect dep on ecdsa that's supposed to workaround pip bugs
+ sed -i -e '/ecdsa/s:<0.15::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}