summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-28 18:42:57 +0100
committerSam James <sam@gentoo.org>2022-04-05 04:18:34 +0100
commit3e68863904071fd2db1939037e114d4f6db99deb (patch)
tree6806877848d6a0ee48bc21df8b20c279f611ca89 /dev-python
parentdev-util/ROPgadget: new ebuild (diff)
downloadgentoo-3e68863904071fd2db1939037e114d4f6db99deb.tar.gz
gentoo-3e68863904071fd2db1939037e114d4f6db99deb.tar.bz2
gentoo-3e68863904071fd2db1939037e114d4f6db99deb.zip
dev-python/python-ptrace: new ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ptrace/Manifest1
-rw-r--r--dev-python/python-ptrace/metadata.xml19
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.9.8.ebuild31
-rw-r--r--dev-python/python-ptrace/python-ptrace-9999.ebuild31
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/python-ptrace/Manifest b/dev-python/python-ptrace/Manifest
new file mode 100644
index 000000000000..7a47cd79cd44
--- /dev/null
+++ b/dev-python/python-ptrace/Manifest
@@ -0,0 +1 @@
+DIST python-ptrace-0.9.8.tar.gz 107064 BLAKE2B fedaf62f5f42816222dc5cf3be1d378a872ec981ed3f8f2ffd43f365baf34e093fec4bd6e62f5374b7e8aca786ef12ba7d73270332b40de99cb027bd656b3c1c SHA512 7bbb3ef2228d6f23d34170107b02793ed92f74257b5f2dcf4d96662ca09c9752ff971c7e810724fe9e6a7d914893597e03f67bd6a818af8ec1f63145f25f4c1b
diff --git a/dev-python/python-ptrace/metadata.xml b/dev-python/python-ptrace/metadata.xml
new file mode 100644
index 000000000000..c5f4fb2ed06e
--- /dev/null
+++ b/dev-python/python-ptrace/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system
+ call to trace processes) written in Python.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vstinner/python-ptrace</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-ptrace/python-ptrace-0.9.8.ebuild b/dev-python/python-ptrace/python-ptrace-0.9.8.ebuild
new file mode 100644
index 000000000000..c87c6168a30e
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.9.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python binding of ptrace library"
+HOMEPAGE="https://github.com/vstinner/python-ptrace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vstinner/python-ptrace"
+else
+ SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ ./runtests.py --tests tests/ || die
+}
diff --git a/dev-python/python-ptrace/python-ptrace-9999.ebuild b/dev-python/python-ptrace/python-ptrace-9999.ebuild
new file mode 100644
index 000000000000..c87c6168a30e
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python binding of ptrace library"
+HOMEPAGE="https://github.com/vstinner/python-ptrace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vstinner/python-ptrace"
+else
+ SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ ./runtests.py --tests tests/ || die
+}