summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-08 09:42:31 +0000
committerSam James <sam@gentoo.org>2020-11-08 09:43:35 +0000
commit3e80c49a992b69608c0bd77b05b6783838dbe4fe (patch)
tree8d60ce35056ba9363bd4102264f5843650929976 /dev-python
parentprofiles: Update GNOME 2 era deprecation list (diff)
downloadgentoo-3e80c49a992b69608c0bd77b05b6783838dbe4fe.tar.gz
gentoo-3e80c49a992b69608c0bd77b05b6783838dbe4fe.tar.bz2
gentoo-3e80c49a992b69608c0bd77b05b6783838dbe4fe.zip
dev-python/translate-toolkit: bump to 3.2.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/translate-toolkit/Manifest1
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.2.0.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index bc3c8b99f9c2..4e1ea5d0bb31 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,2 +1,3 @@
DIST translate-toolkit-2.5.0.tar.gz 7679224 BLAKE2B 927b0dcfc0836ed2f2589d70f5789fc6d8b23a3e80bf4ef0054704ca12e4b5287a7e3b2a90992197bae6fc0acee1ea9d93a8eff05f6e5182f9269ca2aa9e5a66 SHA512 c4ff8fe9e7cc5b44a5448391ecbcfc454bf32d3794267e67824b020ca78cfbeba1283287a42f07859cd197a413fe8171ad5e31375f60fec77f334642ed2ad13e
DIST translate-toolkit-2.5.1.tar.gz 5984081 BLAKE2B 55e158d0d354f181a4e23d9638306eb82bda0dd3133a507de682a54c4197d36ae6ad6bf3d733eb841d9406933407eb98c5874a13e55c7840a672971e87721d94 SHA512 57bdd7f824527955fde6db3a69ffadc27814336c6f792d08bb70e56e95a646d0366e8a3a48ac187ef62804f79dd8a61a4a0b76c8a28e57047c310fcfdf79e999
+DIST translate-toolkit-3.2.0.tar.gz 6029254 BLAKE2B fe4c30e09fcba6755a928775f931f1027bb5678606e74aa435fd5803642ab39b8b55d763bb96dba6b1a957d6656cfca4ec6400b735afd8df7f2c1273ac173c89 SHA512 1045762a5c63cc2bc8459b61a85ef56e4f1d1f705d74646b8235169f22d8d5aa4ab5e3599af52a860d9e434df0fad3e98836b0c021bb0a9697b36a59edbfb6ec
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.2.0.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.2.0.ebuild
new file mode 100644
index 000000000000..2dfbd4ae55b4
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.2.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="https://github.com/translate/translate"
+SRC_URI="https://github.com/translate/translate/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc +html +ical +ini +subtitles +yaml"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="doc? ( >=dev-python/sphinx-3.0.2 )"
+DEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ !dev-python/pydiff
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
+ >=dev-python/python-levenshtein-0.12.0[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Prevent unwanted d'loading in doc build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" \
+ -e "/html_theme/ s/sphinx-bootstrap/classic/" \
+ -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( "${S}"/docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ local deselect=(
+ # Not packaging optional phply for now.
+ # Seems inactive upstream.
+ --ignore translate/convert/test_php2po.py
+ --ignore translate/convert/test_po2php.py
+ --ignore translate/storage/test_php.py
+
+ # Need installed 'pocompile' from this pkg
+ # distutils_install_for_testing doesn't cover fully
+ --deselect 'translate/storage/test_cpo.py::TestCPOUnit::test_buildfromunit'
+ --deselect 'translate/storage/test_po.py::TestPOUnit::test_buildfromunit'
+ --deselect 'translate/storage/test_pypo.py::TestPYPOUnit::test_buildfromunit'
+ --deselect 'translate/storage/test_mo.py::TestMOFile::test_output'
+
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ --deselect 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ --deselect 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ )
+
+ if ! use ini; then
+ deselect+=(
+ --ignore translate/convert/test_ini2po.py
+ --ignore translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ deselect+=(
+ --ignore translate/storage/test_subtitles.py
+ )
+ fi
+
+ # translate/storage/test_mo.py needs 'pocompile'
+ distutils_install_for_testing
+
+ pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ rm -Rf docs || die
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+
+ python_optimize
+}