summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2018-06-22 19:31:53 +0200
committerHanno <hanno@gentoo.org>2018-06-22 19:31:53 +0200
commit3e941cc42ed0273be2ee2bf3cd066ff0d6abe61a (patch)
tree6642aba2cf60186642aa2567978d1dfdcdcba41b /dev-python
parentapp-misc/neofetch: Version bump 5.0.0 (diff)
downloadgentoo-3e941cc42ed0273be2ee2bf3cd066ff0d6abe61a.tar.gz
gentoo-3e941cc42ed0273be2ee2bf3cd066ff0d6abe61a.tar.bz2
gentoo-3e941cc42ed0273be2ee2bf3cd066ff0d6abe61a.zip
dev-python/python-axolotl-curve25519: Initial commit.
Python library for axolotl-based protocols like OMEMO, see https://bugs.gentoo.org/608882 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-axolotl-curve25519/Manifest1
-rw-r--r--dev-python/python-axolotl-curve25519/metadata.xml11
-rw-r--r--dev-python/python-axolotl-curve25519/python-axolotl-curve25519-0.4.1_p2.ebuild19
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-axolotl-curve25519/Manifest b/dev-python/python-axolotl-curve25519/Manifest
new file mode 100644
index 000000000000..e9d3d04f14a7
--- /dev/null
+++ b/dev-python/python-axolotl-curve25519/Manifest
@@ -0,0 +1 @@
+DIST python-axolotl-curve25519-0.4.1.post2.tar.gz 79941 BLAKE2B 51f616670e23591bd77a3b75ecfb487ad5b0360d49cccd736041a3dd12665e19695aea1c772336dbc9642b6ddd2772e1169f02369943bf5311b0ffb6a664fb3d SHA512 2cd0b8607fd1fa7654a5dd02f4594e9617b0553913a59dda1292867de9f6c2160e4b56ec74f83f3d4ef9259e1c77828dd3cd3f58ecb10076d6c9180c61e7d8ef
diff --git a/dev-python/python-axolotl-curve25519/metadata.xml b/dev-python/python-axolotl-curve25519/metadata.xml
new file mode 100644
index 000000000000..3d3866fb9b46
--- /dev/null
+++ b/dev-python/python-axolotl-curve25519/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-axolotl-curve25519</remote-id>
+ <remote-id type="github">tgalal/python-axolotl-curve25519</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-axolotl-curve25519/python-axolotl-curve25519-0.4.1_p2.ebuild b/dev-python/python-axolotl-curve25519/python-axolotl-curve25519-0.4.1_p2.ebuild
new file mode 100644
index 000000000000..4291ed002ca5
--- /dev/null
+++ b/dev-python/python-axolotl-curve25519/python-axolotl-curve25519-0.4.1_p2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_P="${PN}-${PV/_p/.post}"
+DESCRIPTION="Python module for Ed25519 signatures"
+HOMEPAGE="https://github.com/tgalal/python-axolotl-curve25519"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""