summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-18 08:47:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-18 09:54:44 +0200
commit3f666a44aecf0e382d1dc3915057cce99a8bed8c (patch)
tree7f919cdc42f3db189811873d18ee8f97b348a284 /dev-python
parentdev-python/nuitka: Remove old (diff)
downloadgentoo-3f666a44aecf0e382d1dc3915057cce99a8bed8c.tar.gz
gentoo-3f666a44aecf0e382d1dc3915057cce99a8bed8c.tar.bz2
gentoo-3f666a44aecf0e382d1dc3915057cce99a8bed8c.zip
dev-python/nuitka: Bump to 0.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.9.6.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 5e936409ff73..85094745f9c3 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-0.9.5.tar.gz 3858378 BLAKE2B 0b8aa2b191caaa348fda81af41d7a4ad486479742acb929c6e0f0c1ec08b06ca02c5cae46b986c569a8bb792e15fbb90e49db9ece3b226d4e09c054b4311f079 SHA512 4e0def27cc12f4b37debb509c015ba9e56649e82ecede31c142b7c420424364fb243932bd146397bfb82aea1591a06566b346a1b2c6d64cf26cdc59eb77cf875
+DIST Nuitka-0.9.6.tar.gz 3858273 BLAKE2B 5fbe454c5f5612d94342b1247b463a4248a35123d7d4515dadb4c9f4cf5b6714f55e1972d55f60cfdfe65ca97af5fae2cfc92009b274ccf9adaf944217a39333 SHA512 6088459a12f5506a547d40a4c3f0f16f8ab470ee4875d36dfad97e4ba25d7cdc25cae1115a11dd7752dafe51d6c83d80798c74a110c995e47ba127d9b2afbf81
diff --git a/dev-python/nuitka/nuitka-0.9.6.ebuild b/dev-python/nuitka/nuitka-0.9.6.ebuild
new file mode 100644
index 000000000000..5b987e13729d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.9.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}