summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-02-19 19:05:00 +0800
committerIan Delaney <idella4@gentoo.org>2016-02-19 19:05:00 +0800
commit3fa8c80f897b8fd34f90bd7c2d8a98b896e516be (patch)
tree00d3401c69073fcead751e001a428dcad480fe34 /dev-python
parentx11-themes/smplayer-themes: version bump (diff)
parentdev-python/jaraco-collections: fix indentation for 1.3.1 (diff)
downloadgentoo-3fa8c80f897b8fd34f90bd7c2d8a98b896e516be.tar.gz
gentoo-3fa8c80f897b8fd34f90bd7c2d8a98b896e516be.tar.bz2
gentoo-3fa8c80f897b8fd34f90bd7c2d8a98b896e516be.zip
Merge remote-tracking branch 'remotes/sbraz/jaraco.collections'
Pull request: https://github.com/gentoo/gentoo/pull/879 l be ignored, and an empty message aborts
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild2
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.3.2.ebuild49
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 56ee04da2326..de2cc2b413ce 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1 +1,2 @@
DIST jaraco.collections-1.3.1.tar.gz 8616 SHA256 27e3d67f94372d70be25f46a48796441ca719aedbd4a411835e71e88455bbe66 SHA512 812fbb66543e204f09f4dc35fc43888b3e8e1cbbf4a2a0e75a0589286e1ee5b303dc30b93696d8fc952bb3dddab95d8ed5ddb09ad4511ad4e12069fb87a93386 WHIRLPOOL c8730e3bd1eb1950b523ce62e31f7e2d2fd46bacdcacd7c57b9b55f95cff51e025e47813af1777d362f83401822a4015fdd386e977bbbd26f9c1a130ff7aa65a
+DIST jaraco.collections-1.3.2.tar.gz 8965 SHA256 8587fcfa89d81d639687184502cddb4868e3dc5b9a73827ee2bfe8455ab27e57 SHA512 2369e9194fba5b25294ff5977def201b14d1ae72ddce08b5163995fcb530e55046f24354a0144f9272e822c38b468f493f262d56d2d0f6edab315be90f5fca70 WHIRLPOOL adb24717b71bce2f4d4ccae216eb9fd638bd8457a6c465c73fff32e045900ca08e8cc3a2bd49e9f55f6d7897caaae2894a74c10eac343c40498e7ab2a18c712a
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild
index e54b66f95192..6412a98bd3d9 100644
--- a/dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild
+++ b/dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild
@@ -20,7 +20,7 @@ IUSE="test"
PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
-dev-python/six[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.3.2.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.3.2.ebuild
new file mode 100644
index 000000000000..300540df568b
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test; then
+ if has_version "${CATEGORY}/${PN}"; then
+ die "Ensure $PN is not already installed or the test suite will fail"
+ elif ! has_version "dev-python/jaraco-text"; then
+ die "Ensure dev-python/jaraco-text is installed or the test suite will fail"
+ fi
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}