summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-30 05:54:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-30 10:27:40 +0200
commit3fdb5b3f05ee413743dd221b60aa5719a99dcfd5 (patch)
tree1e63c263147b89b31e5320b16061149bb63275f2 /dev-python
parentdev-python/pypy3_10: Bump to 7.3.13 (diff)
downloadgentoo-3fdb5b3f05ee413743dd221b60aa5719a99dcfd5.tar.gz
gentoo-3fdb5b3f05ee413743dd221b60aa5719a99dcfd5.tar.bz2
gentoo-3fdb5b3f05ee413743dd221b60aa5719a99dcfd5.zip
dev-python/pypy3: Bump to 7.3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy3/pypy3-7.3.13.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.13.ebuild b/dev-python/pypy3/pypy3-7.3.13.ebuild
new file mode 100644
index 000000000000..ecf195f8f782
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYVER=3.10
+DESCRIPTION="A fast, compliant alternative implementation of the Python (${PYVER}) language"
+HOMEPAGE="
+ https://www.pypy.org/
+ https://foss.heptapod.net/pypy/pypy/
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0/pypy310-pp73-384"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+gdbm ncurses sqlite tk"
+
+RDEPEND="
+ =dev-python/pypy3_10-${PV}*:${SLOT}[gdbm?,ncurses?,sqlite?,tk?]
+"
+
+src_install() {
+ dodir /usr/bin
+ dosym pypy${PYVER} /usr/bin/pypy3
+}