summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-05 00:56:13 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-05 13:19:17 +0100
commit407473d02d85005da6970399250c15c361a46ff9 (patch)
tree5c297008fdc059fd60633e1ec4ae52314cee5d71 /dev-python
parentprofiles: unmask latest audacious 3.9 series (diff)
downloadgentoo-407473d02d85005da6970399250c15c361a46ff9.tar.gz
gentoo-407473d02d85005da6970399250c15c361a46ff9.tar.bz2
gentoo-407473d02d85005da6970399250c15c361a46ff9.zip
dev-python/pypy: Remove unnecessary LD_LIBRARY_PATH
The pypy executable has $ORIGIN-based rpath.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy/pypy-5.9.0.ebuild1
-rw-r--r--dev-python/pypy/pypy-9999.ebuild1
2 files changed, 0 insertions, 2 deletions
diff --git a/dev-python/pypy/pypy-5.9.0.ebuild b/dev-python/pypy/pypy-5.9.0.ebuild
index 3eff562c4ad6..4c264728fc8d 100644
--- a/dev-python/pypy/pypy-5.9.0.ebuild
+++ b/dev-python/pypy/pypy-5.9.0.ebuild
@@ -220,7 +220,6 @@ src_install() {
einfo "Generating caches and byte-compiling ..."
local -x PYTHON=${ED%/}${dest}/pypy-c
- local -x LD_LIBRARY_PATH="${ED%/}${dest}"
# we can't use eclass function since PyPy is dumb and always gives
# paths relative to the interpreter
local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy/site-packages
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index 62d8a0f73b85..2929a14e1eba 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -226,7 +226,6 @@ src_install() {
einfo "Generating caches and byte-compiling ..."
local -x PYTHON=${ED%/}${dest}/pypy-c
- local -x LD_LIBRARY_PATH="${ED%/}${dest}"
# we can't use eclass function since PyPy is dumb and always gives
# paths relative to the interpreter
local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy/site-packages