summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-20 14:51:48 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-20 15:40:54 +0200
commit4082d8ba710a563e772278eda7d577b0d97337f9 (patch)
tree3a21c741227c00308484eea05fdf1cd319e685ad /dev-python
parentdev-python/pylint: Add missing RDEP on backports-functools-lru-cache (diff)
downloadgentoo-4082d8ba710a563e772278eda7d577b0d97337f9.tar.gz
gentoo-4082d8ba710a563e772278eda7d577b0d97337f9.tar.bz2
gentoo-4082d8ba710a563e772278eda7d577b0d97337f9.zip
dev-python/pytest-pylint: Add pkg needed for aiohttp-cors tests
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-pylint/Manifest1
-rw-r--r--dev-python/pytest-pylint/metadata.xml7
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild37
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
new file mode 100644
index 000000000000..03c43526189a
--- /dev/null
+++ b/dev-python/pytest-pylint/Manifest
@@ -0,0 +1 @@
+DIST pytest-pylint-0.7.1.tar.gz 5648 SHA256 2378eecfef82afc90430fbd578f65d35f6b9cf59319d75f826d9bc30922c5b28 SHA512 e2a7802f90ea25a909094e8bc67570eb631d6ab6dc130bb5cca1738ae09d069b4fa6c3c1349d9d62188a924138e832a3a37c8c5c8964290c95d69eecbadbd09f WHIRLPOOL 848102ab28293954b140a635ec9f0f6b41d3eb591fe00bd665912e689143431b78564316a17b388ad6044c2f4e7caf5c6dda1b1a498e3a20e6959de2f8d55b6d
diff --git a/dev-python/pytest-pylint/metadata.xml b/dev-python/pytest-pylint/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/pytest-pylint/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
new file mode 100644
index 000000000000..d8c094245298
--- /dev/null
+++ b/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check source code with pylint"
+HOMEPAGE="https://github.com/carsongee/pytest-pylint"
+SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # pytest grabs the options from tox.ini automatically
+ # but setup.py does not declare pytest-pep8 as a dep,
+ # so it's missing from env created by distutils_install_for_testing
+ sed -i -e 's:--pep8::' tox.ini || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}