summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-27 07:42:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-27 09:05:07 +0200
commit418e7c056953cd72ab6231e87a84cb9f277c1192 (patch)
tree69c4d219fc9a5994bebbc03a339d49a36f3735c1 /dev-python
parentdev-python/google-api-python-client: Bump to 2.14.1 (diff)
downloadgentoo-418e7c056953cd72ab6231e87a84cb9f277c1192.tar.gz
gentoo-418e7c056953cd72ab6231e87a84cb9f277c1192.tar.bz2
gentoo-418e7c056953cd72ab6231e87a84cb9f277c1192.zip
dev-python/moto: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-2.2.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 0b33f6869237..075dc8a2d92a 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -10,3 +10,4 @@ DIST moto-2.0.7.tar.gz 1565849 BLAKE2B 1c6491828a43156fd347bcce80f3440cd8d4964e2
DIST moto-2.0.8.tar.gz 1569426 BLAKE2B 746313241d49558ab49d7e2116406f128a315a9fca40956808e7f901e91518551a1f75c95c9ce5c92534221d1db3e01a3baa2cef6cadab9a9d024cc30d8ce0e2 SHA512 5cf1a47c97100b76ad9b69787ce4df00f24f93ba1a36a242cea535ede649af457ff043b44f1cce4a4e44b6735844652f69271f18edac0748b636f4e519545018
DIST moto-2.0.9.tar.gz 1614328 BLAKE2B 0bb9e3dcc0c25476b7fdabeecc31be6904a21d6a77f6ce3d9c9c176625873d30c55321c8939ecb8bbc91ee64faab9cd7231150dfdcbd4d5d7d3dc8eae614d9f2 SHA512 41b32aa192dd5c5052a90f345f29e696f9cc6abb3698ea0b738f8805fc920f4abf7d418a64aecf6efd66162aad631c88754d5e4e349ca2ba5b393771038219cb
DIST moto-2.1.0.tar.gz 1638267 BLAKE2B ee778cab1a9a448408bbc495a148201bb016c2ba29076062360db23d86d725758303c32e1fb1a3f9e11112deb1cbca686fc956ddafd259fd942654510ba12147 SHA512 cae18324200d827a1750c5dbe2df2ea68dc66a5b8ff40b4c873f7511d576417c1a2b20203cc126d84b99b1aec5ef8700825271893933e6cc4bd61c0082b9e9be
+DIST moto-2.2.0.tar.gz 1650655 BLAKE2B 9969de2fb323b2deb272eb47727884054a35827a5db382f83a4177cf6cac5339f89164d05c288a977bc1895a204d13d02069e8b37880ea3d04374f6ed4d6be47 SHA512 7eabb515f94920af9b8f028afaaa51e27983f7bfd73f66c29fc191e2f3dd3e8939ddac67de0127c67c35cbc17c3500a7390103b26c85056780c865aadeb5e1d9
diff --git a/dev-python/moto/moto-2.2.0.ebuild b/dev-python/moto/moto-2.2.0.ebuild
new file mode 100644
index 000000000000..7c79594ac4fb
--- /dev/null
+++ b/dev-python/moto/moto-2.2.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-tempfile[${PYTHON_USEDEP}]' python3_{6,7})
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-python-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ dev-python/dicttoxml[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.9.201[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.12.201[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unpin indirect dep on ecdsa that's supposed to workaround pip bugs
+ sed -i -e '/ecdsa/s:<0.15::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local ignore=(
+ # incompatible versions?
+ tests/test_core/test_decorator_calls.py
+ tests/test_s3/test_s3_classdecorator.py
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network' ${ignore[@]/#/--ignore }
+}