summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-13 07:12:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-13 07:30:08 +0200
commit41d6a062f94ec4950b8fc9819342d1a4a2e7e688 (patch)
tree00e482daea1be3ba656ab10e7f0878118d11560d /dev-python
parentdev-python/pyicu: Bump to 2.9 (diff)
downloadgentoo-41d6a062f94ec4950b8fc9819342d1a4a2e7e688.tar.gz
gentoo-41d6a062f94ec4950b8fc9819342d1a4a2e7e688.tar.bz2
gentoo-41d6a062f94ec4950b8fc9819342d1a4a2e7e688.zip
dev-python/google-auth: Bump to 2.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.6.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 62a3223fc179..4b5805f41fb9 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-2.6.0.tar.gz 188477 BLAKE2B 19baf9ec41e2b8667b8800687f4920d0e53df6cbfd17830e352f808b1438b21d952a4480f3b0fbc8e83dd215c0cd49b393f4798952eea1eb808b5417d578af85 SHA512 160fae0afcebd62dc0d46bf5e1102be34c6084cf188941105facd00b4a9b2bf6b36b58623e84595111849af0cb16b4f4a09b1e13ce095be025831fa4e7241b4c
DIST google-auth-2.6.2.tar.gz 189490 BLAKE2B 5506b4d316a40274cd8ce0cea8c6a76b882e14f4f7e28f5a50e67c8828353d3078f713f874e36ba4c81537228325cf19c7ea1c3040b04d4b6338e456a8622024 SHA512 196bcec8f90ddc7ba95f03576f496aab38526c2305d729db806f07c0b44e578c6bfcb3a79224f4edaacb8760a3c7bb17a0af90cb2986aff3fdc5f767328fb247
DIST google-auth-2.6.3.tar.gz 189685 BLAKE2B 68718ce4031c4e764dcfec19361b034ed5e1efa602d5c734b61a853020f40aaa856f9d9a3b964470e148fbfcb081dbc7d2c8bf0a53fc843d9360dbc72623bcdf SHA512 cba3228dbc0887c127d50cc45eb134e3a0b2bea044b8a1e65807918a3808e550fd58217a236c07b6cb908e5a080d9c1c1a2e9ee1853968d8c0bd50b7228ea262
+DIST google-auth-2.6.4.tar.gz 189668 BLAKE2B fe1f660c80095bae4772c78e223f8ba2be1ee749f4571249236fee84abd9a165d08c1acb5dad4ee61accd86c5b60c66befb24c9cbc5665b95bc587dddf99ecb7 SHA512 616004ad945e88dd9561abfcb29c69a0ade5163d6175191bf9421a2d59620a042ae352d833fc20e5f31e20b929dda391a35aa2d391b17af221bc4044f82663f9
diff --git a/dev-python/google-auth/google-auth-2.6.4.ebuild b/dev-python/google-auth/google-auth-2.6.4.ebuild
new file mode 100644
index 000000000000..35f8032960a3
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.6.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}