summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-02 13:01:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-02 13:01:33 +0100
commit42a1ac223b0db52a2a5fa4a90c2012091e1f06d4 (patch)
treeca2346c8ce85206cdd923f667696479a03fa0c63 /dev-python
parentRename dev-python/{python- → }recurring-ical-events (diff)
downloadgentoo-42a1ac223b0db52a2a5fa4a90c2012091e1f06d4.tar.gz
gentoo-42a1ac223b0db52a2a5fa4a90c2012091e1f06d4.tar.bz2
gentoo-42a1ac223b0db52a2a5fa4a90c2012091e1f06d4.zip
dev-python/recurring-ical-events: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/recurring-ical-events/Manifest1
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.0.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index a2c17c918b30..a82ae4fb0199 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1 +1,2 @@
DIST python-recurring-ical-events-2.0.0.gh.tar.gz 325608 BLAKE2B 386ab8a54343fb02c15938801c15b31c8c8ba6bd0888a677268625fcba5571724d53c42f9d093ea8590d6e3557c151b73f9fb532a1bea194bc6d7032e04946e9 SHA512 676bc074a4d9ddb2bf0aefe8e118eab6e80479bb0d585b9f4c50f4bd49c7adf03e484b34bdf01596bb012c903a8017644ff74026d333f13f5c7df2c4326ab18c
+DIST python-recurring-ical-events-2.0.1.gh.tar.gz 326015 BLAKE2B c85d0626f86b90c5c597d9f437f66d0e6cf5c4afbf8f6c521ccf52562a16953fe13c0804f23386276adc252620fcfb6fda69ccbe90ad8b1a4b105f5d5cd34939 SHA512 f12807767a903a90e2348a416bb78873f40238653cc83d50cf51080cf5f214df8b83dca71095b440e73fac9193c10bcd42ea4129edfe3a42607a85b45dfef03b
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.0.1.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.0.1.ebuild
new file mode 100644
index 000000000000..77305260c9e3
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)