summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-10 12:46:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-10 12:48:38 +0200
commit42e153391592da77f88cc735368489f073a29ea7 (patch)
treec9b967711108b1085ef105b8080cfd1ba97bc38d /dev-python
parentdev-python/et_xmlfile: Port to py3.9 (diff)
downloadgentoo-42e153391592da77f88cc735368489f073a29ea7.tar.gz
gentoo-42e153391592da77f88cc735368489f073a29ea7.tar.bz2
gentoo-42e153391592da77f88cc735368489f073a29ea7.zip
dev-python/openpyxl: Bump to 3.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/openpyxl/Manifest1
-rw-r--r--dev-python/openpyxl/openpyxl-3.0.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index a562823bbc02..7aa5bdb3d45a 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1 +1,2 @@
DIST openpyxl-3.0.0.tar.bz2 2405154 BLAKE2B d14e529c73cebd3eab6a4d93dc38c1807d38a5396032b4df77bc7af5d98b5b68369f1b44cce83d77592e7aca673ca497d49a1fafc1f0bcca3c0aff19486ea8db SHA512 fc0c31b1ae486f6fc8802dbd6ea2efee65e788b452240985202617109113dfccb5b26bfa94c2ac42a0ac218ff75bc310773f96122da1522537c063e8d55309f4
+DIST openpyxl-3.0.3.tar.bz2 2407120 BLAKE2B 8a746409d3424014150bad797923f076ac8ba0ab24ffe0ee75c1d65f02accbeecfdc0ae5d2c6025d0fa937cf0f1c75c8837a84ba0f9d63b3778c14c2899df4ba SHA512 7a17a21a4f3be391e7ab72ef6c5f6342094404f68a9e9ca69f874f1ac2441d81699b91224cd1ccd4fe3e7e5c99ca59088ee532bbd2e6edcab40c27a8f1898095
diff --git a/dev-python/openpyxl/openpyxl-3.0.3.ebuild b/dev-python/openpyxl/openpyxl-3.0.3.ebuild
new file mode 100644
index 000000000000..fbd7e799e45c
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+# https://bitbucket.org/openpyxl/openpyxl/issues/1308/include-tests-in-pypi-tarballs
+SRC_URI="https://bitbucket.org/${PN}/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )"
+
+distutils_enable_tests pytest