summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-18 07:59:20 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-18 08:59:47 +0200
commit4304fc7724f01f7bd9c1bb1bf66bab02e564a4e6 (patch)
treef5b61d641fea22ee6822a80b99d1788c8680ea8b /dev-python
parentmedia-libs/gstreamer: keyword 1.20.2 for ~loong (diff)
downloadgentoo-4304fc7724f01f7bd9c1bb1bf66bab02e564a4e6.tar.gz
gentoo-4304fc7724f01f7bd9c1bb1bf66bab02e564a4e6.tar.bz2
gentoo-4304fc7724f01f7bd9c1bb1bf66bab02e564a4e6.zip
dev-python/botocore: Bump to 1.26.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.26.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5b91aa86cfbd..6a3063caa019 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.25.9.tar.gz 8962451 BLAKE2B 5930499f514d5e9b9f0fa0c87a2461071a0432bb3957779a4669448bd7b34e94a5339598703419f36c01e505c8487217a4f525ce63832bc97ad35ef584ef45f3 SHA512 533c5ff383e53aa2b00a83b182207e9dd2d40ea000c7a0f1e74e30989c6c15f54fd26eb67375ceeb90c1a6ab158bda7de75ac40fe6b14614209ebb7063b9e2a1
DIST botocore-1.26.0.tar.gz 8968864 BLAKE2B fc07441c4a759273a1abe6826048082b0e2ce38964de507a9091d5898d998ffb30e9bab835c9a6be2d3d01c15813230fda3a1d0457c5e7aa8573fc262cd9e4d4 SHA512 2bc8cd2c7db5549fa1f8f1364d42a4a6463b1fc8d0a80cd5026ec5f765b2a02108274eb33a6d5d00b3bb07a30351b458e1829b547c07134420a6aed343526990
DIST botocore-1.26.1.tar.gz 8972136 BLAKE2B cf5d18d87fe5e78f6bb623e82dea9ec712867301e7b1fdd46724eb3aa37b7395d91dc206bc9329df96bab9c8072c8b071eaaea767848794db349982c630ab0d2 SHA512 c18160d1eb6f9feb6b4db2441c360112c1d8f88d8d2a3624f89b6ee4815c200c68d70601fbea1c93682af506cc6809a7e34568f543a25adbfd7ca09c309236ff
+DIST botocore-1.26.2.tar.gz 8990271 BLAKE2B 95ddae48b54ba0455959a95eb4dc992bf1a28b5b0004c8004298bea30eb729cc20d0bf7b189a0e62a12939365fd106ccfc06a00092b3229077b665bdcaebd86f SHA512 df478a29511a9436bcab16dca448d4d196988402a326fd8be8f0dd4fbfab0b97ef16b31f241c44e9f9973bbeafc99d79f317838e0e6a83f25299218fd5fce1ac
diff --git a/dev-python/botocore/botocore-1.26.2.ebuild b/dev-python/botocore/botocore-1.26.2.ebuild
new file mode 100644
index 000000000000..f9d3152de4e1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.26.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.26.0-py311.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}