summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-08-10 14:06:39 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-08-10 14:06:51 +0200
commit446201cb1cbd11cc22a71e04030b8c3ed91d16bc (patch)
treedac8489a8d9247ba392de631c6942da379592e8d /dev-python
parentsys-block/zram-init: bump to 3.8 (diff)
downloadgentoo-446201cb1cbd11cc22a71e04030b8c3ed91d16bc.tar.gz
gentoo-446201cb1cbd11cc22a71e04030b8c3ed91d16bc.tar.bz2
gentoo-446201cb1cbd11cc22a71e04030b8c3ed91d16bc.zip
dev-python/reportlab: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.3.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index a806f6f8ddf9..146296a469fd 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -2,3 +2,4 @@ DIST pfbfer-20070710.zip 677333 SHA256 fb1462ff6ce8efae58a0c496f0537c5ac16d4895c
DIST reportlab-2.6.tar.gz 1954170 SHA256 76c3cda08f6eac9b0adf0e3c86202fe5e9cb075c00503bef5760cd9e75ec34ff SHA512 d1173231ec6924c225808607edd287b11095cda1856554ff42efb5911285b766f43b79d8747ea2867221aa5c158455ee864dbe903ceffeae535938d2fef59131 WHIRLPOOL ff177ec570d581eee76f9a54ee95b16c928a1351e85f1906baa36aa270dda6ea41d4da6441274cf4eee00624b5ddb2eb855bf4792b1cba658cc4729399598358
DIST reportlab-3.1.44.tar.gz 1946392 SHA256 f6c22e4afefd1aed0e85f1c1216eee5e74d2eb77d53963feab0172b321b636d5 SHA512 b14b19a1772516ef182fe64ce50f032a1f76834aae9ea4c3f017eec902d84e839a4f3b648bd3ede3579df68654dec027d17c8c9878c580938e16c79ec3ac764f WHIRLPOOL 646e8eb5d4192edb37bc7570629bf2b4e2ff6e6fd35d9e7fa78a0e28be1759793dd4779fff60c7a08522e665c4cb0d3feac4b384324e4f4050be569877154f50
DIST reportlab-3.2.0.tar.gz 1948090 SHA256 72e687662bd854776407b9108483561831b45546d935df8b0477708199086293 SHA512 7b5c01ec7b9ccd404f98b8db1dbe01cb829cf0f1482c29090874996fb1e2ee9296d860c3ff9b7addecad9769c4e7558c0ea51ae4d9c07cbc0cc5ad69b2d8ea9b WHIRLPOOL 42c1432476b038677b42feeb1fefc6753c01a28e515d1edd4613c21f105d783d3196634b4ca0837359049811439ab7e177cbdb1c153aa8a7e80a34e71149e1da
+DIST reportlab-3.3.0.tar.gz 1959255 SHA256 f48900b9321bcb2871a46543993bd995148d769a11a9e24495f25b4ec0bbe267 SHA512 a6dbe5db13a9e430855ba8139310d8f04ade221c340467c2e0f5bf60c700f17148069358beb057f1667217a09b71ba1ae3112bd02e7c8de00e53a8f852acb8df WHIRLPOOL a62cb9ecd2f85324e8e847365346e4fbd64ef098032a54884149db43f4a9f42a0358747a185f1d87107472689bd08f86f70f976da49d09806fc4acf1b175f4f2
diff --git a/dev-python/reportlab/reportlab-3.3.0.ebuild b/dev-python/reportlab/reportlab-3.3.0.ebuild
new file mode 100644
index 000000000000..efe6f96db896
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.3.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} ) # Tests crash with pypy
+
+inherit distutils-r1 flag-o-matic prefix
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="http://www.reportlab.com/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/pillow-2.4.0[tiff,truetype,${PYTHON_USEDEP}]
+ media-libs/libart_lgpl
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-2.2[${PYTHON_USEDEP}]
+ app-arch/unzip
+"
+
+PATCHES=(
+ "${FILESDIR}"/reportlab-no-pip.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ sed -i \
+ -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
+ -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
+ src/reportlab/rl_config.py || die
+
+ eprefixify setup.py
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ pushd tests > /dev/null || die
+ "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( demos/. tools/pythonpoint/demos )
+
+ distutils-r1_python_install_all
+}