summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-13 09:00:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-13 10:56:00 +0200
commit458d981e4fa079b350e016f28a56acb5c020a66d (patch)
treeab08d6d33440d00c11b4b7db50f28553d4f5237a /dev-python
parentdev-python/rfc3339-validator: Bump to 0.1.4 (diff)
downloadgentoo-458d981e4fa079b350e016f28a56acb5c020a66d.tar.gz
gentoo-458d981e4fa079b350e016f28a56acb5c020a66d.tar.bz2
gentoo-458d981e4fa079b350e016f28a56acb5c020a66d.zip
dev-python/google-api-python-client: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 64f9c9bf9157..2115ab045928 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.2.0.tar.gz 24631108 BLAKE2B 377b87d30a0adb2bdbf983e9821e8be5db371e70572d79cafc1c4d231206461d50373b87aed5927cf5a485c3c1b21819db2719107cf58472551a7a0f858d8090 SHA512 9e921aa4b3868f85ecc3eb572d465c13851b1dfa0e84d11706821d5d02511cd4ae4fab4b9b55c606446d5753dccb973a99de888fbfa890aa1fcb6083fde976de
DIST google-api-python-client-2.3.0.tar.gz 24912943 BLAKE2B 60233808f0f6243c37e8915791975e9aa10fa2d82e54c183582db9712dc36920d7d99f6caa67a25a96b1806ae9f96fd4f371010472b753f7a80d5e4fab49bd3e SHA512 11b9ba2f6417c017d47c9563460c38afdbfd01658e6c0f1812b1cdd1068b04bd37bb362e2ade4214fcc9a89d758f31bc977e281b093793a48641a2b7d926715e
+DIST google-api-python-client-2.4.0.tar.gz 24853833 BLAKE2B 4ed2083a9bb8b4f8fe31ab5dbd7875c0c36c972cdb0f71a59565fe4eb23ff1ef0a40794acd7af9646c1ee3904fbab3caaeb2700a3660b66d3069d2bc4f811e76 SHA512 db545850b9d2746e3bcf7b4a2f12b0d4827bd68f44d5627fd80d39bff2ca3303c8d520f72ee17637fe700bc935548706ce885ff0d7fe737ae157668e0314fbc6
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.4.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.4.0.ebuild
new file mode 100644
index 000000000000..5ab50082b8d7
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.13.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest ${deselect[@]/#/--deselect }
+}