summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-09 20:16:45 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-09 20:45:09 +0200
commit4615b8e6f0ae987f989e06f684572062f88c79f7 (patch)
tree6c0c3eddbf9e8395a71ca4f6199e5944e9d3841e /dev-python
parentdev-python/pytest-asyncio: add 0.23.5 (diff)
downloadgentoo-4615b8e6f0ae987f989e06f684572062f88c79f7.tar.gz
gentoo-4615b8e6f0ae987f989e06f684572062f88c79f7.tar.bz2
gentoo-4615b8e6f0ae987f989e06f684572062f88c79f7.zip
dev-python/Nuitka: add 2.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.0.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index dd0424d53b62..3fc0bf0b9477 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-2.0.1.tar.gz 3928704 BLAKE2B 404b1678b761abd2853baa9998fec3710d152a9affdf747d5ccea0d1dc16b861525379ab1999964f81948557484948f43da15614a397e7d85f2f98d4d09afb3e SHA512 70ca004c4207d176e5d504e185a7554a2df4fde8cb93cee440c14a7d785e6dafd587d205c277a681dcbba40e221c3fa46f240c97ecf08c15e2ca801cac4fcc68
+DIST Nuitka-2.0.2.tar.gz 3930125 BLAKE2B b588e57a216f81f02bc6b50355c3cebf37f94a95c320524ea26a772dfbdbb2c8005f3749c145021c400c921957ea666711ad2b67ab12710f9f9ecaa552aedff0 SHA512 722501f1de174c074a6c95c463888e481b3f9b74ccba7a5bd9cdddf74a23abd46473fe532f22b4c542893d942f009985a330588654852a8f7c2994b543538637
DIST Nuitka-2.0.tar.gz 3964226 BLAKE2B 76ace502390dcb9c10ae9a9dc624575453a0e9c440509b40e74162200d84942be565f07a0877f3bfeb8b82b4f1398f8d7c9150e19d8be58e3f67859f0656277d SHA512 93125344fa8556c0c185dabce14786f52f9db37ba1cbdb1d9fafc08d72be66bbb2bad4e55b12a92c84d85efef6d914fb6ae4e5ca7c4da0574f1892152b111ea0
diff --git a/dev-python/Nuitka/Nuitka-2.0.2.ebuild b/dev-python/Nuitka/Nuitka-2.0.2.ebuild
new file mode 100644
index 000000000000..2df076ff3e01
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}