summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-22 15:48:01 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-23 20:49:01 +0200
commit465d709abd541c9898f214497382eb7153e332cb (patch)
treed658ad6016e031c91209bd3d24ff5f93d0f7ab3c /dev-python
parentdev-python/mdurl: new package, add 0.1.0 (diff)
downloadgentoo-465d709abd541c9898f214497382eb7153e332cb.tar.gz
gentoo-465d709abd541c9898f214497382eb7153e332cb.tar.bz2
gentoo-465d709abd541c9898f214497382eb7153e332cb.zip
dev-python/markdown-it-py: new package, add 2.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/markdown-it-py/Manifest1
-rw-r--r--dev-python/markdown-it-py/markdown-it-py-2.0.0.ebuild43
-rw-r--r--dev-python/markdown-it-py/metadata.xml13
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/markdown-it-py/Manifest b/dev-python/markdown-it-py/Manifest
new file mode 100644
index 000000000000..f6fc23e4fb2c
--- /dev/null
+++ b/dev-python/markdown-it-py/Manifest
@@ -0,0 +1 @@
+DIST markdown-it-py-2.0.0.gh.tar.gz 265346 BLAKE2B f509c3fdc82a2665bb9bca862118c544cf203afbb8454cdbb5f58c58aeadcd1fbd66ef98615ac6501e4fe8ce83d2e668de29d2e67301ddda06d1cbbaf6cf7422 SHA512 226111a8d0e57d9def2076053abfba1b7533bb0cdee569b8e1c7ece2b61ebce49daa263aee673683b83974b7597df0e6d62c1723860af684fe306c55619357ca
diff --git a/dev-python/markdown-it-py/markdown-it-py-2.0.0.ebuild b/dev-python/markdown-it-py/markdown-it-py-2.0.0.ebuild
new file mode 100644
index 000000000000..834cfae053f4
--- /dev/null
+++ b/dev-python/markdown-it-py/markdown-it-py-2.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python port of markdown-it, Markdown parser"
+HOMEPAGE="https://pypi.org/project/markdown-it-py/
+ https://github.com/executablebooks/markdown-it-py"
+SRC_URI="
+ https://github.com/executablebooks/markdown-it-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/attrs-22[${PYTHON_USEDEP}]
+ dev-python/mdurl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Unimportant tests needing a new dep linkify
+ tests/test_linkify.py::test_token_levels
+ tests/test_port/test_fixtures.py::test_linkify
+)
+
+EPYTEST_IGNORE=(
+ # No need to benchmark
+ benchmarking/
+)
diff --git a/dev-python/markdown-it-py/metadata.xml b/dev-python/markdown-it-py/metadata.xml
new file mode 100644
index 000000000000..74090f22137f
--- /dev/null
+++ b/dev-python/markdown-it-py/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">markdown-it-py</remote-id>
+ <remote-id type="github">executablebooks/markdown-it-py</remote-id>
+ </upstream>
+</pkgmetadata>