summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 16:41:41 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 17:02:31 +0200
commit47533d597b9471170d44be376030bc590eb93b7e (patch)
tree92c856357d14e72fa4510e70a887eaf7fc92f1da /dev-python
parentdev-python/dictdiffer: add new dep of sphobjinv (diff)
downloadgentoo-47533d597b9471170d44be376030bc590eb93b7e.tar.gz
gentoo-47533d597b9471170d44be376030bc590eb93b7e.tar.bz2
gentoo-47533d597b9471170d44be376030bc590eb93b7e.zip
dev-python/sphobjinv: import from ::guru
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphobjinv/Manifest1
-rw-r--r--dev-python/sphobjinv/metadata.xml23
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.1.ebuild53
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/sphobjinv/Manifest b/dev-python/sphobjinv/Manifest
new file mode 100644
index 000000000000..6fa2f2762a66
--- /dev/null
+++ b/dev-python/sphobjinv/Manifest
@@ -0,0 +1 @@
+DIST sphobjinv-2.1.tar.gz 1144017 BLAKE2B 71878e1bac5202ab74298b56cd6172236ea524050323e0d6b8bbc0c89f1937d75f10d40b4071cfbe8c9031641e9a0ecb283da908c40840a61c12a7c892438241 SHA512 cde77d73b09b72358b0ac5b0d8f1a748e78dce6664d1b849ba68f5ff70dc43cbcff4581374d0151be29c4d97efe2920c5c00ff68918371243be158031e9554fa
diff --git a/dev-python/sphobjinv/metadata.xml b/dev-python/sphobjinv/metadata.xml
new file mode 100644
index 000000000000..dc83e0f5d0f7
--- /dev/null
+++ b/dev-python/sphobjinv/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription lang="en">
+Using Sphinx?
+
+Having trouble writing cross-references?
+
+sphobjinv (short for ‘sphinx objects.inv’) can help!
+
+The syntax required for a functional Sphinx cross-reference is highly non-obvious in many cases. Sometimes Sphinx can guess correctly what you mean, but it’s pretty hit-or-miss. The best approach is to provide Sphinx with a completely specified cross-reference, and that’s where sphobjinv comes in.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bskinn/sphobjinv</remote-id>
+ <remote-id type="pypi">sphobjinv</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/sphobjinv/sphobjinv-2.1.ebuild b/dev-python/sphobjinv/sphobjinv-2.1.ebuild
new file mode 100644
index 000000000000..9afca30acd78
--- /dev/null
+++ b/dev-python/sphobjinv/sphobjinv-2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx objects.inv Inspection/Manipulation Tool"
+HOMEPAGE="
+ https://github.com/bskinn/sphobjinv/
+ https://pypi.org/project/sphobjinv/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+# This requires pytest-check, but that does not work at all, even if it
+# is installed it still fails to find the check fixture
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/fuzzywuzzy-0.8[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/dictdiffer[${PYTHON_USEDEP}]
+ dev-python/pytest-ordering[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/stdio-mgr-1.0.1[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues \
+ dev-python/sphinxcontrib-programoutput
+
+python_prepare_all() {
+ # --strict option is deprecated in pytest>6
+ sed -i -e '/addopts/d' tox.ini || die
+
+ distutils-r1_python_prepare_all
+}