summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-01-17 01:27:10 +0100
committerSebastian Pipping <sping@gentoo.org>2018-01-17 01:33:48 +0100
commit48dcb73991770537df62cb3120ba57502db0599b (patch)
tree1566ac01d74da42a786bb87a212a2edd02b9da57 /dev-python
parentapp-portage/portpeek: portpeek-2.1.25 stable on amd64. See bug #644824 (diff)
downloadgentoo-48dcb73991770537df62cb3120ba57502db0599b.tar.gz
gentoo-48dcb73991770537df62cb3120ba57502db0599b.tar.bz2
gentoo-48dcb73991770537df62cb3120ba57502db0599b.zip
dev-python/piexif: 1.1.0_beta0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/piexif/Manifest1
-rw-r--r--dev-python/piexif/piexif-1.1.0_beta0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/piexif/Manifest b/dev-python/piexif/Manifest
index 80993f04a877..a9a14608082d 100644
--- a/dev-python/piexif/Manifest
+++ b/dev-python/piexif/Manifest
@@ -1,2 +1,3 @@
DIST piexif-1.0.12.zip 1005725 BLAKE2B ff370dfea7b2e3b0013c484c586a294ed3b1590f9248104927974b4f7d2b82435da8fb0d8345ac23bd724606e0cefc2594ba9fa49c58d0f4f00219c1a4ed6cce SHA512 71de13b30d041c2de2136e9299bea96a0446352815de5358863324743aac6a5e187800214edd209dd212108ce9a0b0b4602aee54dd54f8b058228b255b543c63
DIST piexif-1.0.13.zip 1008345 BLAKE2B f2f1ba520d661bf3f50de41b81ceebdaff8db2d83f76d4202771438d78c30beabf118f5732a5e76a6484fbf2bd850b461a9d1a0b675f12995dd7f3c8bb32e6cf SHA512 4234783a639e777b58eb0b4591a272d7d5e8c116a7a242cf36287e64d15089478c88327a16b4fa75786fc3621a6bf647f6a075fab0708e2d0aed6395f95b92cb
+DIST piexif-1.1.0b0.zip 1010925 BLAKE2B dd0eb4cd98cd77b639d88181f7f50201928d683285c661d6fce98c2cef92adfa0a809f45c3dbd38d25745fb1c88f21d31d45871b328052043abe4a247940db62 SHA512 6549f2b1f4a36b3455d561109fc9bdfc130f668ffa78af45ddd1c9ab9264af26617f8d9c7072b2e097d3951a931fae3d8b495589d665d972097411299e24d6e4
diff --git a/dev-python/piexif/piexif-1.1.0_beta0.ebuild b/dev-python/piexif/piexif-1.1.0_beta0.ebuild
new file mode 100644
index 000000000000..d3d26468042f
--- /dev/null
+++ b/dev-python/piexif/piexif-1.1.0_beta0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_P=${PN}-${PV/_beta/b}
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.python.org/pypi/piexif"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}"/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow )"
+
+python_test() {
+ "${PYTHON}" setup.py test
+}