summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-30 09:18:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-30 14:22:07 +0200
commit49af6d2021876ecf44e70f4f882a6912d571b9a1 (patch)
treeb1c76bc67440bd8a99c9a68fc96f8781b5754f89 /dev-python
parentdev-python/sqlalchemy: Bump to 1.4.12 (diff)
downloadgentoo-49af6d2021876ecf44e70f4f882a6912d571b9a1.tar.gz
gentoo-49af6d2021876ecf44e70f4f882a6912d571b9a1.tar.bz2
gentoo-49af6d2021876ecf44e70f4f882a6912d571b9a1.zip
dev-python/botocore: Bump to 1.20.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.61.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index cdbda42e09bf..6e107f8667c8 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -12,3 +12,4 @@ DIST botocore-1.20.57.tar.gz 7654823 BLAKE2B 7a92bb0fa470ee6d73eb6289e1b332ef96c
DIST botocore-1.20.58.tar.gz 7649484 BLAKE2B eb945897b9c143a7d9149cd9a938de08c6e610da428b8d21cefaacb51606414f90107c6abc91c81bebf4f890bc52adc31ddf3cb942f765557214a91bdda55135 SHA512 9eaa93f9764b732baf7ec3fe9e456b1314f6b253cb19aac7ad8e0e5e3829d1ffda75682d79e20310e3918b2a83c46a451a6f2fb931eecac75be132d358352f76
DIST botocore-1.20.59.tar.gz 7649640 BLAKE2B 7757d85d5ecfdc65d7da607824fa9abf56628395cdd1a4196fd0d1833fe97f8a75285083c1c61ee9dd159b778ee3b9fce07903b7e30097bc386cb6108515f39c SHA512 06850bfd59f9ac562569eb5a2a3e5cb7d4104053f0ab31fc315312122d5c861a68f811d422e9f1850c8449c9387ffc72feef9496a9216da359b2c0b8c713110f
DIST botocore-1.20.60.tar.gz 7666269 BLAKE2B 1e32a46be67cb23bc26592036296adf1410b7d43888bbb27a156f996fe4db0f7e11a048b584671bbd9fb9f9dc3f426c43ffc7b4515227e373b97c1fa3a6ccdf4 SHA512 55bb5514a150b4fe152d2bdc501ea238cce83a81f9593e8984dd94cbeb80389f1feb9ea840ce64198aa2976d1130962f652620da540330fa9627f4fcd1299eca
+DIST botocore-1.20.61.tar.gz 7668184 BLAKE2B 2b48af271b0a7c90f18de0e1742fbf5a7fa9ae024acbcce45c8c18bd5d81b70e83b1be1833aee9ff01e6715c4bc1494483d3f903edde9f76fe3acc5b5f950a64 SHA512 8b79a524c17a70b44587485a27dc5334db8d0f4072beccdbed84599e4405231eaeaeec0a4b0ec01ad302d19c190759b99e80a93b55d2c4f7513045452813373c
diff --git a/dev-python/botocore/botocore-1.20.61.ebuild b/dev-python/botocore/botocore-1.20.61.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.61.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}