summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2019-08-18 12:51:21 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-18 14:56:58 +0300
commit4af779aaf591fb57d4e381e75c4dbde7f77be023 (patch)
tree2ac823c7cd0c33216444f97e22cb00dbd363f8c7 /dev-python
parentnet-misc/dcetest: Port to EAPI 7 (diff)
downloadgentoo-4af779aaf591fb57d4e381e75c4dbde7f77be023.tar.gz
gentoo-4af779aaf591fb57d4e381e75c4dbde7f77be023.tar.bz2
gentoo-4af779aaf591fb57d4e381e75c4dbde7f77be023.zip
dev-python/pycollada: drop old
Drop obsolete 0.6 ebuild. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12739 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycollada/pycollada-0.6.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/pycollada/pycollada-0.6.ebuild b/dev-python/pycollada/pycollada-0.6.ebuild
deleted file mode 100644
index 1cd5c01d2d92..000000000000
--- a/dev-python/pycollada/pycollada-0.6.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-PYTHON_MULTIPLE_ABI=1
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for reading and writing COLLADA documents"
-HOMEPAGE="https://pycollada.readthedocs.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/python-dateutil[${PYTHON_USEDEP}] )
-"
-
-REQUIRED_USE="${PYTHON_REQ_USE}"
-
-DOCS=( AUTHORS.md CHANGELOG.rst COPYING README.markdown )
-
-src_compile() {
- distutils-r1_src_compile
-
- if use doc ; then
- pushd docs > /dev/null || die
- emake html
- popd > /dev/null || die
- fi
-}
-
-src_install() {
- distutils-r1_src_install
-
- use doc && local HTML_DOCS=( docs/_build/html/. )
- einstalldocs
-
- if use examples ; then
- insinto /usr/share/${P}/
- doins -r examples
- fi
-
- install_test_data() {
- insinto $(python_get_sitedir)/collada/tests/
- doins -r collada/tests/data
- }
- python_foreach_impl install_test_data
-}
-
-src_test() {
- test_collada() {
- for script in "${S}"/collada/tests/*.py ; do
- PYTHONPATH="${S}" $EPYTHON "${script}"
- done
- }
- python_foreach_impl test_collada
-}