summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2018-02-25 06:32:50 +0000
committerPatrick Lauer <patrick@gentoo.org>2018-02-25 07:28:20 +0000
commit4b00afdadaa15b7c2262dd6224a183696b50d8c3 (patch)
treeac065d18982d56179250e195884223738c33201c /dev-python
parentapp-admin/keepass: remove 2.37 (diff)
downloadgentoo-4b00afdadaa15b7c2262dd6224a183696b50d8c3.tar.gz
gentoo-4b00afdadaa15b7c2262dd6224a183696b50d8c3.tar.bz2
gentoo-4b00afdadaa15b7c2262dd6224a183696b50d8c3.zip
dev-python/peewee: Bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-2.8.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index c182267d082a..20e175ad366b 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1,2 +1,3 @@
DIST peewee-2.7.4.tar.gz 608818 BLAKE2B 3749b84b903240851f4f765a1d19d9629600563991b4474027e69f134bdd176abed322b37de69ce99412ecfa19bef78d6d8a52b3629481a99a0e762841d8a1f3 SHA512 c72391316c8bd1f712bcb26d4d6e5ef386a415da536d78cade35d42bbb9c8c6d7b0494bf329bd67e3ac5b91a2d76e97365376b0e91a5c6a5b78ab1696f7576cb
DIST peewee-2.8.3.tar.gz 639529 BLAKE2B 2d7bd7745b406e2b512a277667cf4c393cdc8ccf193af719d49e9c7e39bce1da3a634c0ef39efda8dbbdb5bdeb9ed5084abf8a304766f4f0216b1bf9abed2936 SHA512 03a2a24acc12c024d9ffc2ccdc70e763e4879f65221b44cda7ee41083e85e8fa5ffa39227a20baa32368d6bd1f104621bb431740430ef6eb0457225fc78e76e4
+DIST peewee-2.8.4.tar.gz 644430 BLAKE2B cbfc829a7abef3ccbbdc863efa9a04d2ad07f052fad11d0e26d8c4902c60c01ad532ae127166ca253f0f656fe9c69d1f1044779d3d9e612e5348c72c10582b1d SHA512 1fa421d3622c63f42901e1673ed1fb47676030861df9758bed801afbcc4ab3e793650fce30e79c7b39d7388a0a2230bfe1a378e43e9b7eafbb29d4bd354ee057
diff --git a/dev-python/peewee/peewee-2.8.4.ebuild b/dev-python/peewee/peewee-2.8.4.ebuild
new file mode 100644
index 000000000000..2a0505fdaa22
--- /dev/null
+++ b/dev-python/peewee/peewee-2.8.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -i -e "s#test_suite='tests',##g;" ./setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Testsuite run using runtests.py does not require deps listed in previous ebuild
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}