summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-30 17:47:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-30 17:50:05 +0200
commit4c26a6b1d22b75f819b555af8388672f1a0ac06c (patch)
tree7a93a09af7a411fff220876de215b64e0ede1201 /dev-python
parentnet-misc/spice-gtk: remove libressl support (diff)
downloadgentoo-4c26a6b1d22b75f819b555af8388672f1a0ac06c.tar.gz
gentoo-4c26a6b1d22b75f819b555af8388672f1a0ac06c.tar.bz2
gentoo-4c26a6b1d22b75f819b555af8388672f1a0ac06c.zip
dev-python/line_profiler: Bump to 3.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-3.2.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 29d93958e281..aca1ef51a124 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,2 +1,3 @@
DIST line_profiler-3.0.2.tar.gz 45185 BLAKE2B 04e617cc7b6c9686192281ab1cdfdef2cfc6ce3c7aa6b9962ed2369620618af8835b93bafe89f8d1288b45d4120d71f728ec577d5c5d035699c2d7a49d6be7c1 SHA512 9a5d1821c02fc063081854ba98a17eca21af65d5aecf4ce32c67806d31bf0c936291a30409845ce6f94211cdaaaf0859ab5e2b437e1a086fd4f60fc2a0fd2742
DIST line_profiler-3.2.1.gh.tar.gz 54639 BLAKE2B 8840ac41397aa5d5c0cb94dec5f673a021a9bad18a7d67d73a2d90bf59745c5e35f205d67d28edd3ceade075320c6fe00426d5cf536b9b2953fbbf90539a5e9a SHA512 6e4e0fcb44df6a4eeafa66e8254e511ef0a0c616e9c2bb4bac6bc29df5efa1849f9e75e998770ec6fbe62916a22b17465cdc6eeee6c61ffa52658a9bdb773490
+DIST line_profiler-3.2.2.gh.tar.gz 50780 BLAKE2B 79c5f7f73adaf940e34f96ef799faf08e7a6218cd9346dc3aa86211d04f0cdfe309de23d11f43292aaca121e78df27d0d07ec3efd129e1cc6778b6f8ae83cbbf SHA512 a7279db406adfdae08d375fa18869fdc2276fe360ffb791aa65b13a028470504cd45acfbaa7ccb1c44fb1a5622d9400c5a889f13230514b9d392f09b439af0fd
diff --git a/dev-python/line_profiler/line_profiler-3.2.2.ebuild b/dev-python/line_profiler/line_profiler-3.2.2.ebuild
new file mode 100644
index 000000000000..d9613ca310d6
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-3.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+# force it to match scikit-build
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/pyutils/line_profiler/"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+# technically, the package claims to support non-scikit-build build
+# but it's clearly unmaintained and broken at the moment
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/scikit-build[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd tests || die
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}