summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-29 14:05:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-29 14:18:45 +0200
commit4d35faf38282603c833da573a9c72e73f3c0bc3b (patch)
tree92f28b02434f11fb0a165e78df97f239894c3c82 /dev-python
parentdev-python/ephemeral-port-reserve: New package, v1.1.4 (diff)
downloadgentoo-4d35faf38282603c833da573a9c72e73f3c0bc3b.tar.gz
gentoo-4d35faf38282603c833da573a9c72e73f3c0bc3b.tar.bz2
gentoo-4d35faf38282603c833da573a9c72e73f3c0bc3b.zip
dev-python/werkzeug: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.1.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 2fb866053ed0..e6e4e00f14ef 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,2 +1,3 @@
DIST werkzeug-1.0.1.gh.tar.gz 907482 BLAKE2B d2dcdce8b1bcbb177b52b0915f2c0ac17d235dee3c77b23e81e4b35412d1f53a194d3c7c7f2a5c065ade99797effe72cc464cf6980b12c761a8a919338021660 SHA512 ba82120fb3e96e3a1334c6452d5ba1950fc016d2d147d643bbc2168ccec496f1dea799982ae8c578167155082c0bdbda5d56a23f64b4b6865f97e90e22df022e
DIST werkzeug-2.0.3.gh.tar.gz 897523 BLAKE2B 1f97a2f7184e8e11bb85722becae7cc032ada38a642a2f925f7b81e89c881011889189999d50dab4591fc2e874aac4ab92b0f1531c211468cf352e31b0b8c8d0 SHA512 a205cd981b3e1b481436e483190427ff3808a5ea80abc616ca08d899d0e6a39893a5cb60adc65c99dcab3af47c24b321c71996d719cb7f224de7942b44b1fd69
+DIST werkzeug-2.1.0.gh.tar.gz 833188 BLAKE2B eed6ddc3acec9a69ca983d440d14693750fc0d09cd1f30f66e27267c266ac5a2c81b21cb8d617e8f6fcfb7426bb427c2dc1cafeec92a238424a005d915dffc4f SHA512 acda1e4037e1d525cbd82ed2310ddf55968d14df6656018b910d7200b51569e88cf58957f94f377deb7fe100db03d30016e9dc91e033a298ad54cb34922be30e
diff --git a/dev-python/werkzeug/werkzeug-2.1.0.ebuild b/dev-python/werkzeug/werkzeug-2.1.0.ebuild
new file mode 100644
index 000000000000..f6fb969d94e3
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://werkzeug.palletsprojects.com/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ !alpha? ( !hppa? ( !ia64? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ ) ) )
+ !hppa? ( !ia64? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' 'python*')
+ ) )
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}