summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-07-23 16:53:39 +0000
committerSam James <sam@gentoo.org>2020-07-23 16:53:39 +0000
commit4f552d6bb6610257d078cd4ac0bcf0bbcc0c8faf (patch)
treeee37254a8c20d2ed8d71cf58253792bb3f56f936 /dev-python
parentdev-python/rq: add upstream information (diff)
downloadgentoo-4f552d6bb6610257d078cd4ac0bcf0bbcc0c8faf.tar.gz
gentoo-4f552d6bb6610257d078cd4ac0bcf0bbcc0c8faf.tar.bz2
gentoo-4f552d6bb6610257d078cd4ac0bcf0bbcc0c8faf.zip
dev-python/rq: bump to 1.4.3
Changes to ebuild: * Add Python 3.8 * Fix setuptools dependency Not doing tests yet, because they require running Redis, which is tricky in sandbox. Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.4.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index b9c1385dab9c..f6fb3743c42e 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1 +1,2 @@
DIST rq-1.3.0.tar.gz 50906 BLAKE2B 073ef65c90b2f4cab7505148133cf9e8652f6915bcb34d96b61fca2eb3096d5eb8fb506dfa3d22f402d4ef7ff8e5456faa3bdf7ad6586cfa563b7b2c2da8cb95 SHA512 3c7c3b63a7068ada14c39fa21631fa35d336955c8f5b7b5fbf3d75a99b046abacc2ff28a3a58fc03d587be8bf8e22eea33d31142d3be880afc49287a004ff782
+DIST rq-1.4.3.tar.gz 52258 BLAKE2B fd2bb19239ac3011005b34cf041e7736794a27b2097a7ff1808a716d45ad224ad349e316f172308175174f59ff0d3d2bbe0c6778bd66cdad6755da2740898c0d SHA512 177c748148a109efaeddf14b3847e7980882f385ba0e346ccfa72983d584f1c739417383c6eec83370a66f1ceeb5f955de9d5ccf87e4136074aa52e2f9144bd3
diff --git a/dev-python/rq/rq-1.4.3.ebuild b/dev-python/rq/rq-1.4.3.ebuild
new file mode 100644
index 000000000000..64bbcfda25c7
--- /dev/null
+++ b/dev-python/rq/rq-1.4.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.0.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"