summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-18 16:03:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-18 16:25:51 +0200
commit4f5665a65be36a5038b06be32fbbd872d1b8f3d6 (patch)
treeeb2ee9b07190b177066c394d588678b20d53eece /dev-python
parentdev-python/rencode: depend on dev-python/wheel (diff)
downloadgentoo-4f5665a65be36a5038b06be32fbbd872d1b8f3d6.tar.gz
gentoo-4f5665a65be36a5038b06be32fbbd872d1b8f3d6.tar.bz2
gentoo-4f5665a65be36a5038b06be32fbbd872d1b8f3d6.zip
dev-python/pytest-timeout: Bump to 1.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-timeout/Manifest1
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 98751e5d0151..e65343bff15f 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1 +1,2 @@
DIST pytest-timeout-1.3.3.tar.gz 11627 BLAKE2B e20348cc461ad03e95c22a16e753b72441ee70da9769214f4d07db15818a8997339ced47244b15de62a61107eb749dff8d6f41ddb4720c925ef1e6eb9962db27 SHA512 633f5aee550d568e403b958f4490ecb828eb322811c9f18cfefb26613be4fc36da14232ecbef8666fcf2dc693a93674c00a853ab546ea8328a07ea34da79fb84
+DIST pytest-timeout-1.3.4.tar.gz 12255 BLAKE2B c8991e0255a490048f43e1163d0315cb8fabfaf9d96deb476e2d59da7efce8c63da09b1e8e6f9d6f3fe82b3c6f67608b5e5db117e6378a041ca6e5ba9c71fc05 SHA512 29af25f3c3776d9ef63c6b7217ffc6b0cedd873b8cc96be742a642da84d12c8988bb9b409e00850246e554b21908d6fd2207692650b154cf6831f38c4395bc80
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild
new file mode 100644
index 000000000000..1fe275fe5426
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+python_test() {
+ distutils_install_for_testing
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}