summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 12:02:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:44:01 +0200
commit507618765a3adc0daccb86a9b44b9daf21fcb4c0 (patch)
tree281bb4d318e86bbf4ec280ea09d56b8320830e0f /dev-python
parentdev-util/rosdep: fix distutils dep (diff)
downloadgentoo-507618765a3adc0daccb86a9b44b9daf21fcb4c0.tar.gz
gentoo-507618765a3adc0daccb86a9b44b9daf21fcb4c0.tar.bz2
gentoo-507618765a3adc0daccb86a9b44b9daf21fcb4c0.zip
dev-python/rosdistro: bump to 0.8.3
Add py39 Fix distutils depend Closes: https://bugs.gentoo.org/748858 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rosdistro/Manifest2
-rw-r--r--dev-python/rosdistro/rosdistro-0.8.3.ebuild (renamed from dev-python/rosdistro/rosdistro-0.8.2.ebuild)3
-rw-r--r--dev-python/rosdistro/rosdistro-9999.ebuild3
3 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/rosdistro/Manifest b/dev-python/rosdistro/Manifest
index 508cc4132a09..29265cfd33c5 100644
--- a/dev-python/rosdistro/Manifest
+++ b/dev-python/rosdistro/Manifest
@@ -1 +1 @@
-DIST rosdistro-0.8.2.tar.gz 61328 BLAKE2B 2eb9c4ffc7eedaa040c48d3eb914ea08540adc4ff76ef83eb0fcf8d3d83989b499408953d76c7e9e7951488b269eb9bb3cd6b9db15650924e9c814c7aac60a6b SHA512 b96565dc8fbc000ed6b18285b04b435c7e3455b1e0938c7959cdd7f78749e1a0cf02b2eecba47077bec512d4f8b22923012a6496fb06a5d58ae97a859f8bc6c3
+DIST rosdistro-0.8.3.tar.gz 61665 BLAKE2B 2d5084409d8222cd277a710a06616fa914a35fb6750e32df7bdee6b7b0285df1b15648b8255cda4aa5867dba3611c5ea294db4711ebf2cc38a11648092623aab SHA512 19e248497b4001c522a84a52d768bc9f20a08020c88574d1a8345cf2173dc2aadd8a1480d4fddf2285ac579ee69dd0b6d4b930333cd6a9cbe32708efed2e5747
diff --git a/dev-python/rosdistro/rosdistro-0.8.2.ebuild b/dev-python/rosdistro/rosdistro-0.8.3.ebuild
index 13f4c2dec919..35bf601a5669 100644
--- a/dev-python/rosdistro/rosdistro-0.8.2.ebuild
+++ b/dev-python/rosdistro/rosdistro-0.8.3.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
diff --git a/dev-python/rosdistro/rosdistro-9999.ebuild b/dev-python/rosdistro/rosdistro-9999.ebuild
index 13f4c2dec919..35bf601a5669 100644
--- a/dev-python/rosdistro/rosdistro-9999.ebuild
+++ b/dev-python/rosdistro/rosdistro-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then