summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-27 08:44:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-27 09:09:24 +0100
commit516422ff49ba64ba68b85084a08c020971412d61 (patch)
tree433cbfe739489547092a69488f63a8aae9f24629 /dev-python
parentapp-text/xmlto: minor style changes (diff)
downloadgentoo-516422ff49ba64ba68b85084a08c020971412d61.tar.gz
gentoo-516422ff49ba64ba68b85084a08c020971412d61.tar.bz2
gentoo-516422ff49ba64ba68b85084a08c020971412d61.zip
dev-python/botocore: Bump to 1.20.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.17.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 433e7b698d4e..30077819e3b1 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -14,6 +14,7 @@ DIST botocore-1.20.13.tar.gz 7467277 BLAKE2B 9662965ecb4acf1c8ff90e2ee35100c5f14
DIST botocore-1.20.14.tar.gz 7470342 BLAKE2B 894b7471a1d1a483edd1f59bed604e9a389d88cb5035ccbf8149303fef7f135aadc6d7df7446e3969e0d17476f9fae2f30f8c9c3b4d995152d36da3bdd4b06f5 SHA512 d2cf24743aa72171ea6c1d804f189e8428fc24f315bc3f118f802932e081b2c75a53ff5c1803c66e3b23e0adb525d8e842f003a7156dd6311aeacd95c2599693
DIST botocore-1.20.15.tar.gz 7473239 BLAKE2B 7661c6c667b50bfff436752e723b4892c8f2967b4f95f6f7a869671451d2ecae6519fb43e813ba86a912e8003d3ca701c7285bd5f19739b8e1f40654bc419e29 SHA512 bb1f5fd9c7dc995826c6945d5bddbe623c6c40bb44dd0b20fd7806a94669994b836d527566825bd3730eb8a57460072d7da68d1630e287ce949f678700a93d84
DIST botocore-1.20.16.tar.gz 7474906 BLAKE2B 7aabd6ff432309c1716e02f348b4af3883e245cbd5f7f58cec9e08013cac926f9118cabf47054d89c5d079b2e28af446280db2096f3301d9593674b9f63a7c75 SHA512 4e9215c46048b7133f418a2980ab23a62ddb23e3ee1c3198f09a0383c9e9f89ec347dbf6cb24104a1e06086f95d9ea975819a28a6fb5f9fbd7210985e8dbf48a
+DIST botocore-1.20.17.tar.gz 7483893 BLAKE2B 5a9ea5c1d3bc5caa91ea939943d86236d58f24b440d7d0de96356836ee6417c62fece8e782f9fd81e14daefac8919a001adb95e67d42110709b7f07f849b71da SHA512 864f938d07b28341128c06186542c0c214a133f1b7a78990e357436463f7cd1a36031101f6588ee706073b78d4ef99571853658f77755eb9f0739882fc706634
DIST botocore-1.20.2.tar.gz 7446650 BLAKE2B 777dbcbfcd824a7d009ffc3a1aec8afbd14a097c61a49116db37c6957e6046b8cd0011cdcb3cc344944e568e9f24d15d625a51d0d2d87761279b449783ce9f68 SHA512 3e225dfa55febb9d7bf77dfcbf4b75c8505ed4a90a5a86cc6eea750b4ab7d8a2ceb16891d4473b1bd7ce1cfd43642ee32e20eea65a25d9d6da1a5f02067fa050
DIST botocore-1.20.3.tar.gz 7446281 BLAKE2B 536cbe8f6b6c150f3c66468f3e0c51ae0e602f277ff64ee67a2f149c0481fe603b10439e2fa37831b106d7ca4b23d1e7037cfc55c8e7caf06b8f9cf5561d9544 SHA512 ad0982fb9095e4d8e36a5805f5041fa1241526409d6a1fad3628c52d9870e54fd4a828816eb77f39b60f49ade7805e97cd286f7ac4070ebafbb696e513691e0f
DIST botocore-1.20.4.tar.gz 7447611 BLAKE2B 05cb501cf40748ac1053c4687bd6de7a17d9ac31fe688de8d6aaf8047260f230ea14cc947c4c208a11d26477508b38428fdca116b9fa8212c5ee6ac020a6367f SHA512 b3ec1597b1cf4e9d18e21216f9ba703e4ae0a924653d21cfd93eeffbb13041ad96c3cd099ff1c8631bdcd5c7d6a70e6d36848fdbc44de9f7cebf7ee223918743
diff --git a/dev-python/botocore/botocore-1.20.17.ebuild b/dev-python/botocore/botocore-1.20.17.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.17.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}