summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-30 19:49:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-30 20:45:40 +0200
commit527ae4bba39dc0d9d5ecaa4494d73cff4eb47686 (patch)
tree3a31d963d0feba262b453d689f31c3378626b8dd /dev-python
parentdev-python/pikepdf: Bump to 5.1.1 (diff)
downloadgentoo-527ae4bba39dc0d9d5ecaa4494d73cff4eb47686.tar.gz
gentoo-527ae4bba39dc0d9d5ecaa4494d73cff4eb47686.tar.bz2
gentoo-527ae4bba39dc0d9d5ecaa4494d73cff4eb47686.zip
dev-python/botocore: Bump to 1.24.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.24.29.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d8eba447cc10..d2c2196fff37 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,4 +4,5 @@ DIST botocore-1.24.25.tar.gz 8852839 BLAKE2B feb0f5de1d34b9f5a1b20f76480f432059c
DIST botocore-1.24.26.tar.gz 8855676 BLAKE2B ad8e82872429043a9a80d6584a5a8af623ce91b516c045284b8ea618629c7cf65195433691db7eced91969ccb14fc8c7f57956897b528c6861fe84175d46286b SHA512 2f08bcd1db6b9a5ede68be204d68f8fa0f1c906ca8d7dccb69d5775a66f86c990788970194058973a90ada928914ec92cf02d4cba30a85c7619bb38d3b117268
DIST botocore-1.24.27.tar.gz 8856607 BLAKE2B aa149a79106bc6e9460d2b69b032b20d0fcd9b0a4d7dda04ac656e0681aff378267f5c6bde4e64432f309ad4ed89ff8cae50b0dc92f01086f8fbe433e5347ad3 SHA512 1cdeb2926bfdd54eb6805295982891cb02005c01ee74e3394d8680e486fd924f73322fb9ae56730deaf360b0e60c9fd482759d597eadb3dc180cb099beff487c
DIST botocore-1.24.28.tar.gz 8856916 BLAKE2B d662fec904cdfb048582252cfa77dadfcb1fcb58bb61e4b273bda34120825a27bc630d2c7fffd215f8733cdba97534da643da6d5b094f3e2ee3c6bb0a86bb27f SHA512 3f10d5ccd2b8051598adc37e452b057a3b53bc267f9cc3fb71caa18f406e515f008f22d2394a37b194ff4c63477f93791e6bdc09657df5ba59377379227c106b
+DIST botocore-1.24.29.tar.gz 8857387 BLAKE2B b873c369a6a9fe2d44124385f618f1caac2986cdbad2ea53cf9ce481692431ff389de44b055b0128eefbd1e26d8cf205d49cfb22decfa11bf6cba8c00aa5df3f SHA512 dcc836ebe25a510aa13f4ba54be99c0d2d086e6a54d446bd303ecd13f3528f004be92ff6408690ebda84b8c13f83ef19cc4026422c2ad15e3c32abfdbf923e9d
DIST botocore-1.24.8.tar.gz 8798121 BLAKE2B 4ca37ed7be0af62901bf154f75739cc7e07505a809e551884c72d5b5eed334fff1111fc6db016df522564a1f3d9b6f258e8eca96161a734711340bf880b553b5 SHA512 6ac2139694ab199313a0fb9a2f783b12de7f3915d10cba739f4758356a3b84a917c3c394954b6d82d7a62de907c6fe57a3559e2b9a625bb0479e7bacd31d21cc
diff --git a/dev-python/botocore/botocore-1.24.29.ebuild b/dev-python/botocore/botocore-1.24.29.ebuild
new file mode 100644
index 000000000000..3bf7c7cfb689
--- /dev/null
+++ b/dev-python/botocore/botocore-1.24.29.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}