summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-22 18:43:10 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-23 20:49:02 +0200
commit52baf4702858d7a05b5cd0d78ced14abfb5ec2ec (patch)
treebaca3599b42cfe4513edf514f0ef7ff0dda26504 /dev-python
parentdev-python/sphinxemoji: new package, 0.2.0 (diff)
downloadgentoo-52baf4702858d7a05b5cd0d78ced14abfb5ec2ec.tar.gz
gentoo-52baf4702858d7a05b5cd0d78ced14abfb5ec2ec.tar.bz2
gentoo-52baf4702858d7a05b5cd0d78ced14abfb5ec2ec.zip
dev-python/sphinxcontrib_github_alt: new package, 1.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib_github_alt/Manifest1
-rw-r--r--dev-python/sphinxcontrib_github_alt/metadata.xml13
-rw-r--r--dev-python/sphinxcontrib_github_alt/sphinxcontrib_github_alt-1.2.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib_github_alt/Manifest b/dev-python/sphinxcontrib_github_alt/Manifest
new file mode 100644
index 000000000000..c3831670c955
--- /dev/null
+++ b/dev-python/sphinxcontrib_github_alt/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib_github_alt-1.2.tar.gz 4015 BLAKE2B 3d3c70124bbb57dbdba5657e28afa88b8576de1a93e28f283cc546134cf326a9c5205d1e68868b0915ddfbfecafbccd5bd2a5e6c0db9938553ad4e31412eec08 SHA512 846139bddd1d12469f7f1564ec3c7c679cf05c79d5c29e2cd5ab23ae4282b084876e09386c3980ec057bf74590f002e50998cb64c84cfd13042ad095b51f9a60
diff --git a/dev-python/sphinxcontrib_github_alt/metadata.xml b/dev-python/sphinxcontrib_github_alt/metadata.xml
new file mode 100644
index 000000000000..4c0ca89ff16b
--- /dev/null
+++ b/dev-python/sphinxcontrib_github_alt/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib_github_alt</remote-id>
+ <remote-id type="github">jupyter/sphinxcontrib_github_alt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib_github_alt/sphinxcontrib_github_alt-1.2.ebuild b/dev-python/sphinxcontrib_github_alt/sphinxcontrib_github_alt-1.2.ebuild
new file mode 100644
index 000000000000..ea2861ef91c1
--- /dev/null
+++ b/dev-python/sphinxcontrib_github_alt/sphinxcontrib_github_alt-1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="Link to GitHub issues, pull requests, commits and users from Sphinx docs"
+HOMEPAGE="https://pypi.org/project/sphinxcontrib_github_alt/
+ https://github.com/jupyter/sphinxcontrib_github_alt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"