summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-03 16:19:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-06 16:54:44 +0200
commit5481d82ab7adea1b4db73d435be652a497ca57bc (patch)
tree34250a8123607290f2d4255d580122a0fd678806 /dev-python
parentnet-libs/rabbitmq-c: Drop old (diff)
downloadgentoo-5481d82ab7adea1b4db73d435be652a497ca57bc.tar.gz
gentoo-5481d82ab7adea1b4db73d435be652a497ca57bc.tar.bz2
gentoo-5481d82ab7adea1b4db73d435be652a497ca57bc.zip
dev-python/dynd-python: Drop old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dynd-python/Manifest2
-rw-r--r--dev-python/dynd-python/dynd-python-0.6.5.ebuild74
-rw-r--r--dev-python/dynd-python/dynd-python-0.6.6.ebuild74
-rw-r--r--dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch14
4 files changed, 0 insertions, 164 deletions
diff --git a/dev-python/dynd-python/Manifest b/dev-python/dynd-python/Manifest
index 50498c51297d..c3d7732f069b 100644
--- a/dev-python/dynd-python/Manifest
+++ b/dev-python/dynd-python/Manifest
@@ -1,3 +1 @@
-DIST dynd-python-0.6.5.tar.gz 231313 BLAKE2B 423c78d3e634862676622dff4b5f6a999e943b9480fdf9f24da189d19dc76ed8b9b131d64da606c3751d5c25e38206e05bf223f139886fec264a74f9daf51868 SHA512 46af19bc26c8f410ac26d4e756a726a56f2d852bfa21dca03c4c47210ed9074a7e017bdd2ecb1de3d00af37815b4a20885cd7945af4c8536941e9106bcf49f12
-DIST dynd-python-0.6.6.tar.gz 233618 BLAKE2B 9aaa9c5145f3f595c5f6036fc27c80af83e141dca3444b7049b9221504a178e93e088febde6eeac74729e8e9fb30f4fafc174c6c32c9084add87670ab99dc81a SHA512 c6be9acf0a4dd2446d613cc0c251b56fcd529fac733ecd63d0450806d7f4af2191ef4e861d015177140ca997464b591562a9f478ea83638516fab8552ee88c06
DIST dynd-python-0.7.2.tar.gz 184981 BLAKE2B 826a46c7c920533dbd64f310ce6136e37f5d3f7e2bb1190977c72e9c7b65aa9957547b02ca92f5aadc1db268ca4ceda9459036e9fe24a57e090f4312645d348b SHA512 e51df7b368b1f6869338cb12a2f093064b1e7531ef674a83dbc7b9cc1dc6143cbe12cb37273bcc01e7b1066eda541b3b15473bc01e88fd9a8d1b594f6f37eaba
diff --git a/dev-python/dynd-python/dynd-python-0.6.5.ebuild b/dev-python/dynd-python/dynd-python-0.6.5.ebuild
deleted file mode 100644
index 05a89c06c00d..000000000000
--- a/dev-python/dynd-python/dynd-python-0.6.5.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit cmake-utils python-r1
-
-# change each release, to avoid git in tree dependency
-DYND_GIT_SHA1=e5578b6b862c025dd757f77aaae69be48cde5613
-
-DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
-HOMEPAGE="https://github.com/ContinuumIO/dynd-python"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- ~dev-libs/libdynd-${PV}
- >=dev-python/numpy-1.5[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- >=dev-python/cython-0.19[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.6.2-out-of-git-versioning.patch )
-
-src_prepare() {
- cmake-utils_src_prepare
- # each relase comes with a different set...
- # remove forced strong flags
- sed -i \
- -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
- -e "s|@DYND_VERSION@|${PV}|" \
- -e 's|-g -fomit-frame-pointer||' \
- -e 's|-Werror||g' \
- CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_SEPARATE_LIBDYND=ON
- -DDYND_INSTALL_LIB=ON
- $(cmake-utils_use test DYND_BUILD_TESTS)
- )
- python_foreach_impl cmake-utils_src_configure
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
- use doc && emake -C doc html
-}
-
-src_test() {
- testing() {
- cmake-utils_src_make DESTDIR="${WORKDIR}-test-${EPYTHON}" install
- cd "${WORKDIR}-test-${EPYTHON}"/$(python_get_sitedir) || die
- ${PYTHON} -c 'import dynd; dynd.test()' || die
- }
- python_foreach_impl testing
-}
-
-src_install() {
- python_foreach_impl cmake-utils_src_install
- dodoc README.md
- use doc && dohtml -r doc/build/html/*
-}
diff --git a/dev-python/dynd-python/dynd-python-0.6.6.ebuild b/dev-python/dynd-python/dynd-python-0.6.6.ebuild
deleted file mode 100644
index 2c4ec25d899f..000000000000
--- a/dev-python/dynd-python/dynd-python-0.6.6.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit cmake-utils python-r1
-
-# change each release, to avoid git in tree dependency
-DYND_GIT_SHA1=d7ec36c6f1beb0621d6037ab0953db7e4c1b9150
-
-DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
-HOMEPAGE="https://github.com/ContinuumIO/dynd-python"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- ~dev-libs/libdynd-${PV}
- >=dev-python/numpy-1.5[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- >=dev-python/cython-0.19[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.6.2-out-of-git-versioning.patch )
-
-src_prepare() {
- cmake-utils_src_prepare
- # each relase comes with a different set...
- # remove forced strong flags
- sed -i \
- -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
- -e "s|@DYND_VERSION@|${PV}|" \
- -e 's|-g -fomit-frame-pointer||' \
- -e 's|-Werror||g' \
- CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_SEPARATE_LIBDYND=ON
- -DDYND_INSTALL_LIB=ON
- $(cmake-utils_use test DYND_BUILD_TESTS)
- )
- python_foreach_impl cmake-utils_src_configure
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
- use doc && emake -C doc html
-}
-
-src_test() {
- testing() {
- cmake-utils_src_make DESTDIR="${WORKDIR}-test-${EPYTHON}" install
- cd "${WORKDIR}-test-${EPYTHON}"/$(python_get_sitedir) || die
- ${PYTHON} -c 'import dynd; dynd.test()' || die
- }
- python_foreach_impl testing
-}
-
-src_install() {
- python_foreach_impl cmake-utils_src_install
- dodoc README.md
- use doc && dohtml -r doc/build/html/*
-}
diff --git a/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch b/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
deleted file mode 100644
index 29c3541b3274..000000000000
--- a/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- CMakeLists.txt.orig 2014-05-12 14:00:52.000000000 +0400
-+++ CMakeLists.txt 2014-05-12 14:03:39.000000000 +0400
-@@ -86,8 +86,9 @@
- endif()
-
- # Get the git revision
--get_git_head_revision("${CMAKE_CURRENT_SOURCE_DIR}" GIT_REFSPEC DYND_PYTHON_GIT_SHA1)
--git_describe("${CMAKE_CURRENT_SOURCE_DIR}" DYND_PYTHON_VERSION_STRING --dirty --always --match "v*")
-+SET(DYND_PYTHON_GIT_SHA1 "@DYND_PYTHON_GIT_SHA1@")
-+SET(DYND_PYTHON_VERSION_STRING "@DYND_PYTHON_VERSION@")
-+
- message(STATUS "DyND-Python version: ${DYND_PYTHON_VERSION_STRING}")
- configure_file(
- "${CMAKE_CURRENT_SOURCE_DIR}/src/git_version.cpp.in"