summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-13 08:56:38 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-13 13:12:08 +0100
commit5484a67a7061fad6fc24007272c9b84053046ee3 (patch)
tree45e75045d11f7fe2ebe3820ca07a97f0bde8c563 /dev-python
parentdev-python/kaitaistruct: Fix pypi remote-id (diff)
downloadgentoo-5484a67a7061fad6fc24007272c9b84053046ee3.tar.gz
gentoo-5484a67a7061fad6fc24007272c9b84053046ee3.tar.bz2
gentoo-5484a67a7061fad6fc24007272c9b84053046ee3.zip
dev-python/py: Bump to 1.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/py/Manifest1
-rw-r--r--dev-python/py/py-1.10.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/py/Manifest b/dev-python/py/Manifest
index 84b3b6162325..458db88fb1ac 100644
--- a/dev-python/py/Manifest
+++ b/dev-python/py/Manifest
@@ -1 +1,2 @@
+DIST py-1.10.0.tar.gz 206984 BLAKE2B 94abc8f348a0ae1b64a1417fbb5ea1e29929a0a98130a968ed80d92824c242a9614493c8c7f87c3db8294d2baf3bdb35ce0254fe2aac0fb6af2c151b682c5d33 SHA512 7a0eb964067bc01fa4f8ffe70b043abfd4619134fbee2935713e28382085d0b8972c319ed665a643b879b18ce662db8a9bd722937af7cf36c233214eea211dd1
DIST py-1.9.0.tar.gz 210098 BLAKE2B d7f9b22ebaedd12534198912c1fa0be80f42e97751701442e060e1c244b06ab82239fe78a3cc7119fa4df5d87ecfd97bfb2568744693d3ffe9824ae1d73e59f9 SHA512 965b2adfe1b13177629ccfcdf6d0a13460683ca7a01d585163deb1af15d926fc86680d9e51660f6cbb8569f822a4d54ce281c029e363d244ddf67e33b102ad0a
diff --git a/dev-python/py/py-1.10.0.ebuild b/dev-python/py/py-1.10.0.ebuild
new file mode 100644
index 000000000000..98989aafbc2b
--- /dev/null
+++ b/dev-python/py/py-1.10.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="https://pylib.readthedocs.io/en/latest/ https://pypi.org/project/py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# This package is unmaintained and keeps being broken periodically.
+RESTRICT=test
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest