summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-24 22:39:51 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 23:09:45 +0100
commit5488d6c5471b5f5ff6d03af8204561a4398f6121 (patch)
tree0a1462991cb398e75c226b8d6c58420719a2ba0d /dev-python
parentdistutils-r1.eclass: Bump installer requirement and remove hack (diff)
downloadgentoo-5488d6c5471b5f5ff6d03af8204561a4398f6121.tar.gz
gentoo-5488d6c5471b5f5ff6d03af8204561a4398f6121.tar.bz2
gentoo-5488d6c5471b5f5ff6d03af8204561a4398f6121.zip
dev-python/installer: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/installer/Manifest2
-rw-r--r--dev-python/installer/installer-0.4.0_p20220115.ebuild55
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/installer/Manifest b/dev-python/installer/Manifest
index b18a2088dca8..9add80aee415 100644
--- a/dev-python/installer/Manifest
+++ b/dev-python/installer/Manifest
@@ -1,4 +1,2 @@
DIST installer-0.4.0-py2.py3-none-any.whl.zip 451433 BLAKE2B 933b7e63b3d0306213789d493d4df112df26b432d63ecd1f8f21449520c34bd2ad542aac25069043fbb535c44f988dca927625eafd0a5a20489fc3ce2bcf84a2 SHA512 cf303bb422e329a36007b361034144a232ba021d4013bb8678dc7c326544e74ec9a3b3fe8b9d3696433dbbe90d2ce4a0ae8967fb054bd5ed49321d470be729a8
-DIST installer-0.4.0_p20220115-cli.patch 14552 BLAKE2B 6632c1472ae0a578f6c7ed0acf1bb0d89ece924626b68c0daa28d9a7d93826837adaf6b0d40f048c4f5c2986b4328ca565340137e7b7fa7f407f62ebddc70275 SHA512 f8c6369955e0bde2bff0b935c39748d02659bc6ca0341af405e2c1026cf145479ba0b908bd769cdc05f3cc920f881b894b6a5eb7ace643951e05250ec0486b80
-DIST installer-0.4.0_p20220115.gh.tar.gz 466532 BLAKE2B 6dea3f4bacb52c4983e111d420495ee157076342a823b7062c6e5b3e4d3b70e6b2e9cb024d0c7baba6f88ed70f4303ab071d1882bc9d8dd0726f82a3e406056f SHA512 fbb0d4c8642fa2cbe2fd3be2eef7044a0353f04c67ecce20aafed33a0d7877ff55872ca5ad51390ae7e02cdb7af5dbd57b662085b60d425be95da6643b061eaa
DIST installer-0.4.0_p20220124.gh.tar.gz 468296 BLAKE2B 44763fd05b9e3cc665871817f3a6a417ddc12274ae42989e96ad432af98d42c23ab9f1c1cc37e17d4b9ce06ead7ef0c8227b2b10fe5744c899a9e3ea347e4e33 SHA512 b25fa910e8a7d9a2757af4694bf12a64c8731213a5682ab02bbe472229c99dd9190b1e7663a7632d61cbf0585006b2d4de62115c40f9b132be2c70672e23726d
diff --git a/dev-python/installer/installer-0.4.0_p20220115.ebuild b/dev-python/installer/installer-0.4.0_p20220115.ebuild
deleted file mode 100644
index 1d5d429041ce..000000000000
--- a/dev-python/installer/installer-0.4.0_p20220115.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-EGIT_COMMIT="bf68f7b045ffc08784af03cf2433548c9ee9e8ca"
-DESCRIPTION="A library for installing Python wheels"
-HOMEPAGE="
- https://pypi.org/project/installer/
- https://github.com/pradyunsg/installer/
- https://installer.readthedocs.io/en/latest/
-"
-SRC_URI="
- https://github.com/pradyunsg/installer/archive/${EGIT_COMMIT}.tar.gz
- -> ${P}.gh.tar.gz
- https://files.pythonhosted.org/packages/py2.py3/${PN::1}/${PN}/${P%_p*}-py2.py3-none-any.whl
- -> ${P%_p*}-py2.py3-none-any.whl.zip
- https://patch-diff.githubusercontent.com/raw/pradyunsg/installer/pull/94.diff
- -> ${P}-cli.patch
-"
-S=${WORKDIR}/${PN}-${EGIT_COMMIT}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-# NB: newer git doesn't use mock anymore
-BDEPEND="
- app-arch/unzip
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${DISTDIR}"/${P}-cli.patch
-)
-
-# do not use any build system to avoid circular deps
-python_compile() { :; }
-
-python_test() {
- local -x PYTHONPATH=src
- epytest
-}
-
-python_install() {
- python_domodule src/installer "${WORKDIR}"/*.dist-info
-}