summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2015-09-01 11:00:17 -0500
committerMatthew Thode <mthode@mthode.org>2015-09-01 11:08:06 -0500
commit550c13390c3ace8a2de7c5228f2ac862aee53aae (patch)
treed436687e918876e7601f18b6949f3a90a6f5ab90 /dev-python
parentdev-python/tempest-lib: bup for liberty (diff)
downloadgentoo-550c13390c3ace8a2de7c5228f2ac862aee53aae.tar.gz
gentoo-550c13390c3ace8a2de7c5228f2ac862aee53aae.tar.bz2
gentoo-550c13390c3ace8a2de7c5228f2ac862aee53aae.zip
dev-python/python-glanceclient: bup for liberty
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-1.0.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 6e9c660bf39e..743fcf45af77 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -5,3 +5,4 @@ DIST python-glanceclient-0.17.1.tar.gz 131534 SHA256 79e3426aa76d712a9fde4d4dcef
DIST python-glanceclient-0.17.2.tar.gz 134726 SHA256 56ca8fe2c4f33d9dd9b045073bdd0dba09b1f6ef7af978175966d262678ecd0e SHA512 d66cb2391c6feeeb279a1591bae04405bf78eeb95b6f8bb78a401b28246d6de341cf02c621553e97dce3ddc43dcf8c6bfb5360ff7d6ac54501565fcbe1bac957 WHIRLPOOL cbff98a55f3fcd30335bdb504e61682b04e8f84de5359dc671f834e8a98f441355d89f2a0123e31dc71f0fdf4b522341e54212fb2dd5bb8965a613f4084a62d1
DIST python-glanceclient-0.18.0.tar.gz 132194 SHA256 9784de057ffb8fadd98563452a9f30bfdca6d4531ce166ac2d101cd968a6194a SHA512 091f4a954e58abef40520ecb137fb47e02bd299e9903a83dc9eb26e428e4e0a0f58949e2eead5afaa271ef71e2827f319e72074bf93313ccd506f3374e95367d WHIRLPOOL edfe214cd791baed39f05617b2fa35b3eeae66754b57e9e553f019b3937fe04046bf73c9fa1c811f429a22622777b2507221b712e0b040efb7f8d0e2cb986b71
DIST python-glanceclient-0.19.0.tar.gz 138756 SHA256 45115023cadfdbc24a10b10ca5d003f8f04fd5642b7c8fb565efa566bac4bf51 SHA512 50591b535bb27eaeaeed02f04bd164d4449df1e2b66a6c8abd4fad327e2293b6c9a1e4226ce3f9180d22a33ed2212bd735ad2d91374121e0d062c590a4cc64c5 WHIRLPOOL 9abb606573211c39becef134803e036f7f6b11591ae95d486749e8a62f2a22490c833750ef5234c2502f7aa0cb24dcf62b326249703fbae0dceb3173b7286bf2
+DIST python-glanceclient-1.0.0.tar.gz 149306 SHA256 46cf0c1bad4ec29c8b56c0a16a2c54f4add89fd33e8756285367cfcdd23595b4 SHA512 fc0ef3ff6da41b750fc1972feee65671aa9cb6deeeb08a39ab271aceacc872886edbcabaa0d7f36574a425fac29bd868f6d4682563719249c2fab80c16f19761 WHIRLPOOL 33d293a959e193fcc8297e60a718c99eacf17e55cccca3204bc521fb50b3793cfe3ea68bb4a570e1f50be44f1421c5fe12ee7b038bd5a95344e5f7f8c29c03a0
diff --git a/dev-python/python-glanceclient/python-glanceclient-1.0.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-1.0.0.ebuild
new file mode 100644
index 000000000000..5541f0fdabf3
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-1.0.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+REQUIRED_USE="test? ( doc )"
+
+CDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/tempest-lib-0.6.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.0.1[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
+ sed -i '/^argparse/d' requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 tests && einfo "run flake8 over tests folder passed" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}