summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-24 10:59:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 11:01:20 +0100
commit55e986dd30623895a8489a17a2a4821e1b003e87 (patch)
tree019e8621f981eafcc837d44c8bf2878eed7b12d1 /dev-python
parentdev-python/jaraco-text: Bump to 3.7.0 (diff)
downloadgentoo-55e986dd30623895a8489a17a2a4821e1b003e87.tar.gz
gentoo-55e986dd30623895a8489a17a2a4821e1b003e87.tar.bz2
gentoo-55e986dd30623895a8489a17a2a4821e1b003e87.zip
dev-python/denonavr: Bump to 0.10.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-0.10.10.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index 74ffd4dd3789..e146ef5b791a 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1 +1,2 @@
+DIST denonavr-0.10.10.tar.gz 149803 BLAKE2B a2a034c05cee5b7c6eb51280f4064f41e1228e303043717bb7d4bf08a47230263eb0ab7a96f226ebedaeecd972c1f25f297a1ae3911c44d48949fd113e2e11a9 SHA512 219b04e64055c6d659db09229f895ea3acc90a9d6398d6d53d51753a14779603b8ff983b6c62aa6ce46c0945d11d9e48ff22ca9d9b36a81121cf5dfd4ffac21c
DIST denonavr-0.10.9.tar.gz 152589 BLAKE2B c517e7d2fbdb23f4b684ffbb206528a641ec9d64e48f1d7aa8a4dd1247ca779bb2bda8a9deab1a985d713d275dc68fa6f961205e33b8bcc7749d9cb3c943f752 SHA512 134b940516a312afb03b2c5fa11a5fb68374c6e5d636332e8a7034ee6c94d2baf70b53e979c1c751eaaab6d31822de4450ceddeab12c42dfc9dd74b934593621
diff --git a/dev-python/denonavr/denonavr-0.10.10.ebuild b/dev-python/denonavr/denonavr-0.10.10.ebuild
new file mode 100644
index 000000000000..abf79bb7064a
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.10.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="https://github.com/scarface-4711/denonavr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest