summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-21 07:58:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-21 11:54:14 +0200
commit5663d7e9c706fb220523412dfa0f0d5751533f80 (patch)
tree23c8129bc72169564c594b5e1786338e6c10175a /dev-python
parentdev-python/notebook: Bump to 7.0.4 (diff)
downloadgentoo-5663d7e9c706fb220523412dfa0f0d5751533f80.tar.gz
gentoo-5663d7e9c706fb220523412dfa0f0d5751533f80.tar.bz2
gentoo-5663d7e9c706fb220523412dfa0f0d5751533f80.zip
dev-python/scikit-build-core: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.5.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index 7f2a65bb66fe..897371efb243 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,3 +1,4 @@
DIST scikit_build_core-0.4.7.tar.gz 161024 BLAKE2B a06136ca6144305290dcebacd33690556ce30c28793572adfd7b42b043d4bb7f2e6e8000fcb543608d33a130f7094683a31870aa40067fb24fbb453fed884ccf SHA512 39f99facc920e3a46a3592d15ce9f3ceb90cf92dca8a010546a9cc15d50ea7737951286b6474f2f3f68f206f4fa7d157931fcfa831e122f51266df56ec5f043e
DIST scikit_build_core-0.4.8.tar.gz 163396 BLAKE2B f432d144babd6be45a730e0566cf6fe8bea051b85364b0af26655e0679a0d458f3fd106e816f09557110a6e4e1fed056d1c6454c044ab34dfcc6530cad6020e3 SHA512 55ded022de13bbc60e5abed7b39466751abda3d66a0fa1c094ccd3ab28a93ac3437db2fb8e53381bbe0f7da9985ea5a6fd129af24e6654d3df48c704fb4612f1
DIST scikit_build_core-0.5.0.tar.gz 177478 BLAKE2B e3f3d4bb60fcdc87b32799a663a96bfc994969c3a9dd6c73bd5f27720482cd02b8bbf75f7aee8b39c3b73dc8b6740c526a144b59ecb029e7de3b604dcb1aceb8 SHA512 68bd13b5f97aa498189a61e342bdcb6fa5ea45d8ee73cc557b1e67c9a8d411ef93ea59a954210f48b76e7c1a2f645e4e34686e6fa122929cf0bc69a9f3846600
+DIST scikit_build_core-0.5.1.tar.gz 179718 BLAKE2B 31cd974a3deec188dc97ca708a04badfa8d75a0e66e85a2a814816bac126921aa5531f4f0de56f93a264b98edd341498298e1536502506d7b47ff40ca8bf92da SHA512 de7dd843a7979615a1421bc9ea6c0fde40b72ed94209783f176a5fb427a9fdee497a69e891441591d65d06a3ea619c4c67c9314cf0b7622d19cd88c149b43c7b
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.5.1.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.5.1.ebuild
new file mode 100644
index 000000000000..b3a6b7200a22
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.5.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ )
+
+ epytest -m "not isolated and not network"
+}