summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-11 09:12:46 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-11 09:48:11 +0100
commit58f15f9ca761ce29967d950bb7982346d1c7cbd1 (patch)
treec52081ce4867df5a53dc127f1e36333985d4f6dc /dev-python
parentdev-python/rst-linker: Bump to 2.2.0 (diff)
downloadgentoo-58f15f9ca761ce29967d950bb7982346d1c7cbd1.tar.gz
gentoo-58f15f9ca761ce29967d950bb7982346d1c7cbd1.tar.bz2
gentoo-58f15f9ca761ce29967d950bb7982346d1c7cbd1.zip
dev-python/reportlab: Bump to 3.5.65
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.5.65.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index c9611bc903f5..7bc4be79de14 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -2,3 +2,4 @@ DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f
DIST reportlab-3.5.60.tar.gz 2905122 BLAKE2B 8863e910dac03d5fd1d53880bb9fe83d218641156e481c97b498e462cf9e1e5c6826f2f25fcef7c65cee3dbc7551401bfd1dba6a319532363b7c9cbc9c37e618 SHA512 395ad0c904215ba3ae16efa52140b7cc6f751efd04c70f687a8891806b346d78c75bb29df5aa0d6d49adb6f5638da58704e713ee1500df05424c9dddc38afad2
DIST reportlab-3.5.63.tar.gz 2908785 BLAKE2B 0af6f72063e4a1f4464bf8d847575e23b5d96ced3bdbafa518e56503194e98aed5e07c17fbf6cf07d3d95ef91b3d0d450233024b40368889dc1ef5d8792050fe SHA512 39c940a585695752095b868fa631396193083d9d270512e0e89e766e02d749745b6d0438f2d9f5ec2ea58c7da6aa538a0315fbd7483571ebc2c460035e12a1bf
DIST reportlab-3.5.64.tar.gz 2909252 BLAKE2B 5922ec3083238c2884d7ebede5593a15fa537a8bd72f5cf9b6a84bf1673fe43be2df9f2125f033400c766fdf78a07f4c919b331bbd2215acb950dbbcb971bced SHA512 ac4eb9a7c337ebdde81dcfa9e6b9609aec7fca8451d383c28b9d58e0ea73bd71c328fb2362ba5805b96e10c95dc166d5806eb763c5c325a6d72a9474dce3c422
+DIST reportlab-3.5.65.tar.gz 2909468 BLAKE2B cec88aa00299d329a44379798824a8694f7547a9bb35685b202873387d0b40cdb2bfc864257ee2749c8cc24ed1d26e1ef22c1059fe2e27df38cedae71d55ceda SHA512 a143ff277ab4e9bf667d8334aca9d5b0c959b64eebbd5eda8d6fed95b09cd28544a33bbe5f630753f167b54e63a1a5e04f841c8892712e93d2f8739e9651269a
diff --git a/dev-python/reportlab/reportlab-3.5.65.ebuild b/dev-python/reportlab/reportlab-3.5.65.ebuild
new file mode 100644
index 000000000000..71dd8dad099d
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.5.65.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl
+ sys-libs/zlib:="
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]"
+BDEPEND="
+ app-arch/unzip"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests unittest
+
+PATCHES=(
+ # bug 738312, remove -L/usr/lib from link line
+ "${FILESDIR}"/${PN}-3.5.48-usr-lib-LLD.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ # tests requiring Internet access
+ sed -i -e 's:test0:_&:' \
+ tests/test_platypus_general.py \
+ tests/test_platypus_images.py || die
+ sed -i -e 's:test9:_&:' tests/test_lib_utils.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ mydistutilsargs=(
+ --no-download-t1-files
+ --use-system-libart
+ )
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py -v || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}