summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 13:39:31 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 16:11:41 +0100
commit59168993b864a11e71780b559a0e9ed046340ba6 (patch)
tree65107eecbef6129528d0d4253cf6124d323d8a90 /dev-python
parentdev-python/pytest: Version Bump (diff)
downloadgentoo-59168993b864a11e71780b559a0e9ed046340ba6.tar.gz
gentoo-59168993b864a11e71780b559a0e9ed046340ba6.tar.bz2
gentoo-59168993b864a11e71780b559a0e9ed046340ba6.zip
dev-python/numpy: Propargate latest cahnges to live ebuild
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numpy/numpy-9999.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/dev-python/numpy/numpy-9999.ebuild b/dev-python/numpy/numpy-9999.ebuild
index e170cb939c90..74d9bcb761cd 100644
--- a/dev-python/numpy/numpy-9999.ebuild
+++ b/dev-python/numpy/numpy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -94,16 +94,12 @@ python_prepare_all() {
fi
# don't version f2py, we will handle it.
- sed -i -e '/f2py_exe/s:+os\.path.*$::' numpy/f2py/setup.py || die
+ sed -i -e '/f2py_exe/s: + os\.path.*$::' numpy/f2py/setup.py || die
# we don't have f2py-3.3
- sed \
- -e "/f2py_cmd/s:'f2py'.*:'f2py':g" \
- -i numpy/tests/test_scripts.py || die
-
- sed \
- -e "s:\"cblas\":\"$(pc_libs cblas)\":g" \
- -i numpy/distutils/system_info.py || die
+# sed \
+# -e 's:test_f2py:_&:g' \
+# -i numpy/tests/test_scripts.py || die
distutils-r1_python_prepare_all
}
@@ -127,12 +123,11 @@ python_install() {
}
python_install_all() {
- distutils-r1_python_install_all
+ DOCS+=( COMPATIBILITY DEV_README.txt THANKS.txt )
- dodoc COMPATIBILITY DEV_README.txt THANKS.txt
+ distutils-r1_python_install_all
- # absent in 1.9
- #docinto f2py
- #dodoc numpy/f2py/docs/*.txt
- #doman numpy/f2py/f2py.1
+ docinto f2py
+ dodoc doc/f2py/*.txt
+ doman doc/f2py/f2py.1
}