summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2018-10-27 19:54:00 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-30 10:07:29 +0100
commit595d14eaf504aef961cc6a7831b37306c408831c (patch)
treea4b7521f6ea353c310c0387d201121f867ce6f0f /dev-python
parentsys-libs/compiler-rt-sanitizers: Rebase patches for -9999 (diff)
downloadgentoo-595d14eaf504aef961cc6a7831b37306c408831c.tar.gz
gentoo-595d14eaf504aef961cc6a7831b37306c408831c.tar.bz2
gentoo-595d14eaf504aef961cc6a7831b37306c408831c.zip
dev-python/pytidylib: Bump to 0.3.2 and add python3_7 support
Signed-off-by: Nils Freydank <holgersson@posteo.de> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytidylib/Manifest1
-rw-r--r--dev-python/pytidylib/pytidylib-0.3.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytidylib/Manifest b/dev-python/pytidylib/Manifest
index 7646139e22cb..97c21b78a80e 100644
--- a/dev-python/pytidylib/Manifest
+++ b/dev-python/pytidylib/Manifest
@@ -1 +1,2 @@
DIST pytidylib-0.2.4.tar.gz 86650 BLAKE2B 15212651c83ebbec5b74418f37bfcd0366e9b6cdfc0820953e34ec3142871248df02618a51415a36b84ac8c2e5a12d996ff7301b5bf3a001fb42297df3a98202 SHA512 443e9af0fd458d4f041e3b72415839838a4edc83f8a978e5cc0bdf53202584e269f1ad5df10967d8ae4b98b24dcffcf9f5a54e0e3f6cd620a8a6a20171da0811
+DIST pytidylib-0.3.2.tar.gz 87669 BLAKE2B 57eee794e3a6ba147b778360a12d2417c21579250620854267a83300d918cac0320c768faacb531517b66eed7fd7afc1679e76f2db626f7d7daa80af1667a06d SHA512 24f755ed2607e300711f5a1aee510df3a0a410cc7d8d8f46e065ec8d93c50e436a492cc2831e9d416ab9837497c603f9dc8705da543102813d3264e6de033ca7
diff --git a/dev-python/pytidylib/pytidylib-0.3.2.ebuild b/dev-python/pytidylib/pytidylib-0.3.2.ebuild
new file mode 100644
index 000000000000..1edb2743c4b4
--- /dev/null
+++ b/dev-python/pytidylib/pytidylib-0.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for HTML Tidy (tidylib)"
+HOMEPAGE="http://countergram.com/open-source/pytidylib https://github.com/countergram/pytidylib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="app-text/htmltidy
+ dev-python/setuptools"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv || die
+}