summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-10 12:23:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-10 12:27:43 +0200
commit5cf4455ae7c157ff511f1831a7573e9ef78fb7a4 (patch)
tree73c5ec710df3d63ca92d56eca347c4340831fcd0 /dev-python
parentdev-libs/c-blosc: Add myself as co-maint (diff)
downloadgentoo-5cf4455ae7c157ff511f1831a7573e9ef78fb7a4.tar.gz
gentoo-5cf4455ae7c157ff511f1831a7573e9ef78fb7a4.tar.bz2
gentoo-5cf4455ae7c157ff511f1831a7573e9ef78fb7a4.zip
dev-python/blosc: Unbundle c-blosc
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/blosc/blosc-1.9.1-r1.ebuild (renamed from dev-python/blosc/blosc-1.9.1.ebuild)6
-rw-r--r--dev-python/blosc/files/blosc-1.9.1-unbundle.patch23
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-python/blosc/blosc-1.9.1.ebuild b/dev-python/blosc/blosc-1.9.1-r1.ebuild
index 2cda56af6d43..11fa0fc160a9 100644
--- a/dev-python/blosc/blosc-1.9.1.ebuild
+++ b/dev-python/blosc/blosc-1.9.1-r1.ebuild
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/c-blosc:="
+RDEPEND=">=dev-libs/c-blosc-1.19.0:="
DEPEND="${RDEPEND}"
BDEPEND="
dev-python/scikit-build[${PYTHON_USEDEP}]
@@ -28,6 +28,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-unbundle.patch
+)
+
python_prepare_all() {
export BLOSC_DIR="${EPREFIX}/usr"
distutils-r1_python_prepare_all
diff --git a/dev-python/blosc/files/blosc-1.9.1-unbundle.patch b/dev-python/blosc/files/blosc-1.9.1-unbundle.patch
new file mode 100644
index 000000000000..55af5f0c621a
--- /dev/null
+++ b/dev-python/blosc/files/blosc-1.9.1-unbundle.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2711877..a4c949c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,16 +4,9 @@ find_package(PythonExtensions REQUIRED)
+
+ # Todo: c-blosc provides a CMake package configuration file that we can build
+ # against if blosc is available on the system, etc.
+-# find_package(blosc)
+-# if(NOT blosc_FOUND)
+-set(BUILD_STATIC ON CACHE BOOL "Build a static version of the blosc library.")
+-set(BUILD_SHARED OFF CACHE BOOL "Build a shared library version of the blosc library.")
+-set(BUILD_TESTS OFF CACHE BOOL "Build test programs form the blosc compression library")
+-set(BUILD_BENCHMARKS OFF CACHE BOOL "Build benchmark programs form the blosc compression library")
+-set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+-add_subdirectory(c-blosc)
++find_package(blosc)
+
+ add_library(blosc_extension MODULE blosc/blosc_extension.c)
+-target_link_libraries(blosc_extension blosc_static)
++target_link_libraries(blosc_extension blosc)
+ python_extension_module(blosc_extension)
+ install(TARGETS blosc_extension LIBRARY DESTINATION blosc)